Zasobniki węzła CSM PowerFlex są zablokowane w punkcie inicjowania: 0/2
Summary: Moduły pamięci masowej kontenerów (CSM) Zasobniki węzłów PowerFlex zatrzymują się na poziomie init:0/2 po ponownym uruchomieniu hostów z powodu zastosowanych w nich zmian.
Symptoms
Wszystkie zasobniki węzłów PowerFlex utknęły w init:0/2 i zgłoszony błąd "Warning FailedMount 8s (x6 over 23s) kubelet MountVolume.SetUp failed for volume "scaleio-path-bin" : mkdir /bin/emc: read-only file system " w opisie kapsuły.
Problem wystąpił z operatorem CSM 1.9 i 1.8.1 ze sterownikiem interfejsu Container Storage Interface (CSI) dla PowerFlex 2.13.1 i 2.14.
Cause
Główną przyczyną tego problemu jest to, że operator CSM nie może określić, czy jest uruchomiony w środowisku OpenShift podczas inicjowania. Informacje te są przechowywane w pamięci podręcznej do późniejszego wykorzystania. Jest prawdopodobne, że w momencie uruchomienia operatora następujące polecenie nie zwróciło oczekiwanego wyniku:
oc get --raw /apis | jq | grep "security.openshift.io"
Sugeruje to, że security.openshift.io Grupa interfejsu programowania aplikacji (API) mogła być w tym momencie niedostępna.
W dzienniku operatora, jeśli widzisz [isOpenShift err false]oznacza to, że operator nie jest w stanie określić środowiska OpenShift.
2025-06-17T08:45:38.167Z INFO workspace/main.go:99 isOpenShift err false {"TraceId": "main"}2025-06-17T08:45:38.168Z INFO workspace/main.go:105 Kubernetes environment {"TraceId": "main"}
Poprawny komunikat dziennika określający środowisko OpenShift to:
2025-06-19T00:03:14.913Z INFO workspace/main.go:138 Openshift environment {"TraceId": "main"}
Resolution
- Ręcznie uruchom następujące polecenie:
oc get --raw /apis | jq | grep "security.openshift.io"
and
oc auth can-i get /apis/security.openshift.io --as=system:serviceaccount:dell-csm-operator:dell-csm-operator-manager-service-account
- Oczekiwany rezultat to
# oc get --raw /apis | jq | grep "security.openshift.io" "name": "security.openshift.io", "groupVersion": "security.openshift.io/v1", "groupVersion": "security.openshift.io/v1",
# oc auth can-i get /apis/security.openshift.io --as=system:serviceaccount:dell-csm-operator:dell-csm-operator-manager-service-accountyes
3. Jeśli widzisz powyższe dane wyjściowe, uruchom ponownie operator CSM:
oc delete pod dell-csm-operator-controller-manager-xxx-xxx -n openshift-operators
4. Jeśli dane wyjściowe nie są takie same jak powyżej, poproś klienta o skontaktowanie się z pomocą techniczną firmy Red Hat w celu dalszego sprawdzenia.