Data Domain: wyciek pamięci wtyczki boostfs

Summary: Procesy BoostFS mogą z czasem zużywać nadmierną ilość pamięci fizycznej, szczególnie w środowiskach z wieloma montowaniami. Może to prowadzić do zwiększonego ogólnego użycia pamięci systemowej i pogorszenia wydajności systemu. ...

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

Stopniowy wzrost wykorzystania pamięci po zamontowaniu BoostFS
Procesy BoostFS zużywające znaczną część pamięci systemowej.
Większe wykorzystanie pamięci w przypadku skonfigurowania wielu montowań BoostFS.
Spadek wydajności systemu w czasie
Użycie pamięci wydaje się stale rosnąć, ale nie jest zwalniane.

Cause

Problem jest spowodowany wyciekiem pamięci w bibliotekach skrytek innych firm zintegrowanych z systemem plików BoostFS.
BoostFS używa mechanizmu skrytki do bezpiecznego przechowywania poświadczeń dla jednostek pamięci masowej Data Domain.
Podczas operacji, takich jak montowanie i we/wy, wpisy skrytki są wielokrotnie weryfikowane.
Każda walidacja powoduje alokację pamięci przez bibliotekę skrytki.
Ta przydzielona pamięć nie jest prawidłowo zwalniana, co prowadzi do wycieku pamięci.
Wraz z upływem czasu i przy wielu montowaniach zużycie pamięci znacznie wzrasta.
Wersje, których dotyczy problem:
BoostFS 7.12 i starsze są dotknięte problemem.

Resolution

Uaktualnij BoostFS do wersji 7.13 lub nowszej, w której ten problem został rozwiązany.
Po uaktualnieniu monitoruj wykorzystanie pamięci, aby potwierdzić stabilizację.

Jeśli natychmiastowa aktualizacja nie jest możliwa:
Zminimalizuj liczbę jednoczesnych montowań BoostFS tam, gdzie jest to możliwe.
Okresowo uruchamiaj procesy BoostFS jako tymczasowe środki zaradcze.

Produse afectate

Data Domain
Proprietăți articol
Article Number: 000480507
Article Type: Solution
Ultima modificare: 23 Jun 2026
Version:  1
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.