AppSync: Oracle recovery failing when the source Oracle instance init file contains two entries for log_archive_dest_1

Summary: Oracle recovery failing when there are two database parameter entries in initORADEV.ora on the target host.

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

ASM was in use for the issue reported.

The AppSync Service Plan Events (event log) show:
2021-11-09 18:48:41.335,Recover copy,6c70267c-0e32-4eb0-8d52-64682e5a2451,ORCL_000048,MountHost,AppSync was unable to modify the asm_diskstring parameter on the ASM instance - recovery might fail. Check agent logs for details. Ensure that the asm_diskstring parameter has a non empty value before attempting a mount operation.
2021-11-09 18:48:56.785,Recover copy,6c70267c-0e32-4eb0-8d52-64682e5a2451,ORCL_000040,AS-Server,Recovery operation on host MountHost Failed. Oracle database MountDB failed to startup in mount mode.
2021-11-09 18:49:11.37,Recover copy,6c70267c-0e32-4eb0-8d52-64682e5a2451,ORCL_000042,AS-Server,One or more databases failed to recover. Check server and agent logs for details.
2021-11-09 18:49:13.12,Recover copy,6c70267c-0e32-4eb0-8d52-64682e5a2451,MILE_000005,AS-Server,Recover copy phase for PRODDB completed with errors

The Mount host AppSync agent logs show:
2021-11-09 18:48:26.603 oracle.py[5018]:_execSql() SQLresult: Connected to:
2021-11-09 18:48:26.603 oracle.py[5018]:_execSql() SQLresult: Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production
2021-11-09 18:48:26.604 oracle.py[5018]:_execSql() SQLresult: With the Automatic Storage Management option
2021-11-09 18:48:26.604 oracle.py[5018]:_execSql() SQLresult: 
2021-11-09 18:48:26.604 oracle.py[5018]:_execSql() SQLresult: SQL> SQL> alter system set asm_diskstring='' scope=both
2021-11-09 18:48:26.604 oracle.py[5018]:_execSql() SQLresult: *
2021-11-09 18:48:26.604 oracle.py[5018]:_execSql() SQLresult: ERROR at line 1:
2021-11-09 18:48:26.604 oracle.py[5018]:_execSql() SQLresult: ORA-32001: write to SPFILE requested but no SPFILE is in use
 2021-11-09 18:48:26.604 oracle.py[5018]:_execSql() SQLresult: Disconnected from Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production

However earlier in the AppSync agent logs from the Mount host, AppSync returned two entries for log_archive_dest_1 from a query. Having two entries that are returned is the primary identifying factor for this issue.

The log entry is similar to:
2021-11-09 18:45:41.492 oracle.py[5097]:_sqlQuery() SQL*Plus Query: select 'AppSync_entry:'|| name||'////'|| value from v$spparameter where ISSPECIFIED='TRUE' and name not like 'instance_mode' and name not like 'INSTANCE_MODE';
2021-11-09 18:45:41.741 oracle.py[5125]:_sqlQuery() SQL*plus > AppSync_entry:log_archive_dest_1////location="+FRAPROD" mandatory valid_for=(online_logfile,all_roles)
2021-11-09 18:45:41.741 oracle.py[5125]:_sqlQuery() SQL*plus >
2021-11-09 18:45:41.741 oracle.py[5125]:_sqlQuery() SQL*plus > 'APPSYNC_ENTRY:'||NAME||'////'||VALUE
2021-11-09 18:45:41.742 oracle.py[5125]:_sqlQuery() SQL*plus > -----------------
2021-11-09 18:45:41.742 oracle.py[5125]:_sqlQuery() SQL*plus > AppSync_entry:log_archive_dest_1////location="+FRAPROD"
2021-11-09 18:45:41.742 oracle.py[5125]:_sqlQuery() SQL*plus >
AppSync_entry:log_archive_dest_1////MANDATORY valid_for=(ALL_LOGFILES,ALL_ROLES)

Cause

The issue is due to having two entries for "log_archive_dest_1" in production (SOURCE) init file as shown below:

*.log_archive_dest_1='location="+FRAPROD" mandatory valid_for=(online_logfile,all_roles)'
PROD.log_archive_dest_1='location="+FRAPROD"','MANDATORY valid_for=(ALL_LOGFILES,ALL_ROLES)'

Resolution

Removing the redundant entry for archive log destination resolves the issue.

Produse afectate

AppSync
Proprietăți articol
Article Number: 000194025
Article Type: Solution
Ultima modificare: 28 oct. 2025
Version:  2
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.