AppSync: LDAP Configuration Fails org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException: HTTP 500 Internal Server Error
Summary: After filling all the parameters, and clicking the Apply button, an error message is received after 4-5 minutes when configuring a new LDAP in AppSync. The CPU and RAM remain high. Error message received when LDAP configuration fails: org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException: HTTP 500 Internal Server Error ...
Acest articol se aplică pentru
Acest articol nu se aplică pentru
Acest articol nu este legat de un produs specific.
Acest articol nu acoperă toate versiunile de produs existente.
Symptoms
From AppSync server log:
Then we see the Error:
<Date-time> INFO [default task-8] [com.emc.archway.services.iamservice.KeycloakService] [AppSync server] [] b98e9897-2f9d-4e0f-8f03-f2c3cbc8a190->>> LDAP group sync status is 19999 imported groups, 0 updated groups, 0 removed groups using mapper AppSync LDAP Group Mapper
<Date-time> ERROR [default task-2] [org.jboss.as.ejb3.invocation] [AppSync server] [] WFLYEJB0034: Jakarta Enterprise Beans Invocation failed on component KeycloakService for method public abstract com.emc.archway.securityInterface.LDAP com.emc.archway.securityInterface.IAMService.getLDAPAuthority(com.emc.archway.context.ExecutionContext,java.util.UUID) throws com.emc.archway.errorMessages.ResourceNotFound: javax.ejb.EJBException: org.jboss.resteasy.client.exception.ResteasyInternalServerErrorException: HTTP 500 Internal Server Error
Cause
The limit is 20,000 groups and it is showing 19,999 groups.
Resolution
Modify the search path for AppSync groups so that AppSync does not look into other groups, then retry adding the settings. The issue is resolved by reducing the user and group search path.
Produse afectate
AppSyncProduse
Data Backup & Protection SoftwareProprietăți articol
Article Number: 000228907
Article Type: Solution
Ultima modificare: 10 sept. 2025
Version: 2
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.