Dell Optimizer Presence Detection Setting Cannot Be Modified Without External Monitor Connected

Summary: This article provides information about how the Dell Optimizer Presence Detection setting cannot be modified without an external monitor connected.

Acest articol se aplică pentru Acest articol nu se aplică pentru Acest articol nu este legat de un produs specific. Acest articol nu acoperă toate versiunile de produs existente.

Symptoms

 

Dell Optimizer (DO) version 4.1. x and later includes a setting for Presence detection to allow keeping the Presence Detection functionality enabled while external monitors are connected. This is necessary, since Dell also launched monitors and webcam peripherals supporting presence detection. The Presence Detection feature does not support external sensors (monitor or webcam) and internal sensors (Laptop Camera) simultaneously. The default setting is enabled, but can be configured in the Graphical User Interface (GUI) or Command-Line Interface of Dell Optimizer.
However, the setting itself is only visible in the GUI and can only be changed in the CLI if an external monitor is connected.

  • You cannot find and configure the "Special Use Case" setting "Keep Presence Detection enabled while connected to external monitors" if the system is not connected to an external monitor.
  • As an IT Administrator, you are not able to configure the "Special Use Case" setting "Keep Presence Detection enabled while connected to external monitors" with DO-cli.exe if the system is not connected to an external monitor. The command exits with return code 3

Presence Detection

(Figure 1 - Presence Detection)

   


Cause

This is expected behavior due to user experience design. There is no install switch or other method to force configuration of the setting.

   


Resolution

You must connect an external monitor to be able to configure this setting.

   


Produse afectate

Dell Optimizer
Proprietăți articol
Article Number: 000299986
Article Type: Solution
Ultima modificare: 26 mar. 2025
Version:  1
Găsiți răspunsuri la întrebările dvs. de la alți utilizatori Dell
Servicii de asistență
Verificați dacă dispozitivul dvs. este acoperit de serviciile de asistență.