Avamar: I registri di Avagent mostrano "CR_ERROR" durante la registrazione o il backup

Zhrnutie: I registri di Avagent mostrano l'errore "CR_ERROR"

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

Scenario 1: la registrazione del client non riesce:

avagent.log:

2018/02/20-07:42:30.26300 [agent_main]  agent_message::lowrecv() Unable to recv message size!

2018/02/20-07:42:30.26300 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2018/02/20-07:42:30.26300 [agent_main]  agent_message::receive_message after recv
2018-02-20 13:12:30 avagent Error <5061>: No response to message
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closing socket
2018/02/20-07:42:30.26300 [agent_main]  agent_message::hangup closed connection
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response received an bad status code 'CR_ERROR'
2018/02/20-07:42:30.26399 [agent_main]  agent_commands::check_mc_response ret=9. 
 

-- Oppure --

2019-01-28 12:52:53 avagent Info <6601>: Hostnamelist: client1.avamar.com,171.16.100.200,client1.avamar.com,127.0.0.1
2019-01-28 12:52:54 avagent Info <5472>: Registering with the MCS (10.18.100.200)
2019-01-28 12:52:54 avagent Error <5320>: Received from MCS#100003:client certificate verification failed 100.168.100.20.
2019-01-28 12:52:54 avagent Error <5061>: No response to message
2019-01-28 12:52:54 avagent Error <6210>: Unable to register '/clients\client1' with MCS at 10.18.100.200:30001
2019-01-28 12:52:54 avagent Error <6164>: Registration error: Client ID(CID) missing from response. (< msgver="1" />
2019-01-28 12:52:54 avagent Error <5036>: Unable to register CR_ERROR
 

Scenario 2: la registrazione viene completata, ma i backup si bloccano in "Waiting client" o "Timed-Out End" senza alcun trasferimento dei dati:

avagent.log:

2017/06/14-15:17:43.99699 [agent_main]  agent_message::receive_message message sent, recv ack, timeout 300
2017/06/14-15:18:02.95099 [agent_main]  agent_message::lowrecv() Unable to recv message size!
2017/06/14-15:18:02.95099 [agent_main]  agent_message::recvcapsule capsule: server_avail:1, ret.size=0
2017/06/14-15:18:02.95099 [agent_main]  agent_message::receive_message after recv
2017-06-14 08:18:02 avagent Error <5061>: No response to message
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closing socket
2017/06/14-15:18:02.95099 [agent_main]  agent_message::hangup closed connection
2017-06-14 08:18:02 avagent Error <5038>: Error sending message CR_ERROR    
 

-- Oppure --

avagent Info <7502>: Registration of client /Data_Center1/SharePoint2013/prod_ext/client2.emc.local with MCS avamar-01emc.local:28001 successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3015 VSS successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3023 update successful.
2017-06-14 18:41:57 avagent Info <5928>: Registration of plugin 3001 Windows successful.
2017-06-14 18:41:57 avagent Info <5619>: Registration of client and plugins complete.
2017-06-14 18:41:57 avagent Info <5964>: Requesting work from avamar-01.emc.local
2017-06-14 18:42:16 avagent Error <5061>: No response to message 2017-06-14 18:42:16 avagent Error <5038>: Error sending message CR_ERROR

Príčina

Se avagent Rapporti di registro "No response to message" oppure "CR_ERROR Durante l'handshake iniziale, si è verificato un problema di comunicazione che blocca send/acA questo punto, l'utente deve essere in grado di inviare messaggi tra la griglia Avamar e il client.

Nota: Tutti gli errori in entrambi gli scenari indicano problemi di rete o firewall nell'ambiente del cliente.

Riešenie

È possibile utilizzare la seguente procedura per individuare i colli di bottiglia:

1. Verificare che tutte le porte Avamar necessarie siano aperte nel firewall e possano inviare e ricevere dati.
(da Avamar Server a client e da client ad Avamar Server)

2. Verificare se è presente un software di rilevamento antivirus o malware che blocca i dati sulle porte Avamar.

3. Se il client si trova dietro un NAT, verificare che le tabelle di route siano configurate correttamente.

4. Se si verifica lo stesso errore su tutti i client, assicurarsi che non siano state apportate modifiche alla rete Avamar.

5. Coinvolgere il team di rete per tracciare il traffico di rete dal client guasto alla griglia Avamar e verificare la presenza di pacchetti persi nella rete.

6. Se non è possibile rilevare problemi, raccogliere tcpdump e Wireshark oppure Netmon informazioni e creare una Service Request.

Ďalšie informácie

Risorse di Wireshark:
 
Risorse TCPDump:
  •    https://linuxtechlab.com/learn-use-tcpdump-command-examples(Link esterno)

Dotknuté produkty

Avamar, Avamar Client
Vlastnosti článku
Číslo článku: 000040936
Typ článku: Solution
Dátum poslednej úpravy: 24 sep 2025
Verzia:  8
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.