Avamar:VMwareイメージのリストアに失敗し、「生成されたリストア メタデータの待機のタイムアウト」

Zhrnutie: VMwareイメージのリストアが「Timeout on wait for spawned restore metadata avtar process to complete」で失敗する

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

新しい仮想マシンへのVMwareイメージのリストア、または新しいディスクへのイメージのリストアが次のエラーで失敗します。
 

avvcbimage Error <0000>: [IMG0011] Timeout on wait for spawned restore metadata avtar process to complete


新しいVMまたはディスクにリストアする場合、通常のリストア ワークフローでは、ユーザーが選択したバックアップからVM構成ファイルの「ミニリストア」を実行する必要があります。これらのファイルは、.vmxおよび.vmdk記述子ファイルとしてラベル付けされます。

データがリストアされると、プロキシはリストアされたVM構成を取得し、新しいVM仮想ディスクを構築します。その後、仮想ディスクのイメージのリストアを続行できます。「メタデータ リストア」と呼ばれるミニ リストア ジョブには、デフォルトで5分のタイムアウトが設定されています。vmxリストアは小さい(通常は~15 kb)ため、リストアには数秒しかかかりません。   

ただし、リストア ログでは、この動作が発生します。 

1. 2017-04-14 12:50:21 avvcbimage Info : Process 4486 (/usr/local/avamarclient/bin/avtar) for workorder MOD-1492174248297#99 started
2. 2017-04-14 12:55:21 avvcbimage Error : [IMG0011] Timeout on wait for spawned restore metadata avtar process to complete
3. 2017-04-14 12:59:51 avvcbimage Info : Process 4486 (/usr/local/avamarclient/bin/avtar) finished (code 0: success)


ログ メッセージには、合計所要時間が9分30秒と示されていますが、最終的にはメタデータのリストアが成功しました。しかし、デフォルトのサブプロセス時間5分(300秒)を超過したため、イメージ リストア タスクは失敗しました。

Príčina

Data Domainは、ddboostクライアント(avtar)にインターフェイスへの接続を指示するインターフェイス グループ(ifgroup)で構成されています。このインターフェイスは、クライアント(プロキシ)との間でブロックされています

Data Domainのコマンド ラインまたはWebページで、dd設定を確認します。
設定例: 

sysadmin@ddve# Ifgroup Show Config
Group-name   Status    Interfaces
----------   -------   ----------
default      enabled   192.168.69.80
----------   -------   ----------

sysadmin@ddve  net show config
ethV0     Link encap:Ethernet  HWaddr 00:50:56:98:A6:66
          inet addr:10.240.196.80  Bcast:10.240.196.255  Mask:255.255.255.0


ethV1     Link encap:Ethernet  HWaddr 00:50:56:98:56:8F
          inet addr:192.168.69.80  Bcast:192.168.69.255  Mask:255.255.255.0

In the example above the default Ifgroup  setting will cause the client to initially connect to primary/management interface of 10.240.196.80 but will see the ifgroup settings and try to connect with 192.168.69.80.

RPC has a default time-out value of 180 seconds but the client will try multiple times (3 in this case) which would add up to a total of 540 seconds or 9.5 mins.  After trying three times the connection will fallback to 10.240.196.80 but by this time the image restore job would have timed out.   

From the proxy run this series of commands to confirm the issue replacing the IP addresses as appropriate: 
  1. rpcinfo -p 192.168.69.80 (command stops responding for 3 min) 
  2. rpcinfo -p <data domain fully qualified  hostname> 
  3. rpcinfo -p 10.120.24.49   

Riešenie

解決策
クライアントとData Domainのifgroupインターフェイス間の接続を開きます。
もう1つのオプションは、ifgroupを無効にすることです。

代替策:
たとえば、サブプロセスのタイムアウト値を 10 分 (600 秒) に増やします。これにより、リストアを完了できます。  
これを行うには、パラメーター --subprocesstimeoutsecs=600avvcbimageAll.cmd ファイル、次の場所にあります。 /usr/local/avamarclient/var/ プロキシ上

avvcmimage.cmdファイルの編集の詳細については、以下を参照してください。 

Ďalšie informácie

関連記事: Avamar - VMwareイメージのリストアが致命的なエラー「GetDiskattributed Failed」で失敗しました(Dellサポートへのログインが必要な場合があります)
 

Dotknuté produkty

Avamar Client for VMware

Produkty

Avamar, Avamar Client
Vlastnosti článku
Číslo článku: 000063666
Typ článku: Solution
Dátum poslednej úpravy: 10 okt 2025
Verzia:  4
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.