PowerFlex: No se puede ejecutar el comando ScaleIO. Error: Comando fallido de MDM
Zhrnutie: No se puede ejecutar el comando ScaleIO, error: "Comando fallido de MDM. Estado: Sesión no válida: inicie sesión e inténtelo de nuevo".
Tento článok sa vzťahuje na
Tento článok sa nevzťahuje na
Tento článok nie je viazaný na žiadny konkrétny produkt.
V tomto článku nie sú uvedené všetky verzie produktov.
Symptómy
Cuando se intenta ejecutar un comando desde el administrador de metadatos primarios (MDM), los comandos de ScaleIO fallan con una sesión no válida:
# scli --mdm_ip --login --username admin Enter password: Logged in. User role is Administrator. System ID is XXXXXXXXX # scli --mdm_ip --query_all_volumes Error: MDM failed command. Status: Invalid session. Please login and try again.
Príčina
El problema que hace que el MDM rechace las conexiones es que el usuario de CallHome "Monitor" vuelve a iniciar sesión cada diez minutos y no cierra la sesión. Esto hace que las sesiones de inicio de sesión de los usuarios se acumulen y llenen la tabla de sesiones antes de que el tiempo de espera agotado pueda expulsarlas.
Riešenie
Elimine (o comente) las siguientes dos líneas en mdm/cfg/conf.txt, en ambos MDM:
user_session_hard_timeout_secs=86400 user_session_timeout_secs=28800 Stop CallHome service temporarily
/opt/emc/scaleio/callhome/bin/delete_service.sh
Reinicie el servicio de MDM:
kill
Espere 10 minutos y, a continuación, intente emitir scli después de iniciar sesión e iniciar el servicio Call Home nuevamente.
./opt/emc/scaleio/callhome/bin/create_service.sh
Ďalšie informácie
El error también puede ocurrir si se agota el tiempo de espera de la sesión de la CLI de ScaleIO.
Dotknuté produkty
PowerFlex SoftwareProdukty
PowerFlex SoftwareVlastnosti článku
Číslo článku: 000065938
Typ článku: Solution
Dátum poslednej úpravy: 08 jan 2026
Verzia: 6
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.