Cloud Disaster Recovery Add-on (CDRA) fails to deploy
Zhrnutie: Cloud Disaster Recovery Add-on (CDRA) fails to deploy when a user is part of an organization with a Service Control Policies (SCP) configured.
Tento článok sa vzťahuje na
Tento článok sa nevzťahuje na
Tento článok nie je viazaný na žiadny konkrétny produkt.
V tomto článku nie sú uvedené všetky verzie produktov.
Symptómy
Deployments which are using organizational SCP configured user-accounts have restrictions set that can prevent successful configuration of CDRA when it tries to query AWS and check for IAM policy permission or roles.
Príčina
As a result of restrictions configured from using an organization SCP enabled account, the deployment process fails when it tries to check for 'verifyRolePriviligesForActions' as seen below in log excerpt:
DEBUG [2020-07-16 18:04:33,463] [main] [CdrRole:verifyRolePrivilegesForActions:272]: verifyRolePrivilegesForActions for user DellEMC-cdr-dr-vmc-cdrs-user-01 ERROR [2020-07-16 18:04:33,605] [main] [CdrRole:verifyRolePrivilegesForActions:300]: Insufficient privileges.Missing Permissions for: s3:*, ec2:*, cloudwatch:*, cloudformation:*, rds:*, sqs:*, ses:SendEmail, ses:SendRawEmail, ses:Verify*. ERROR [2020-07-16 18:04:33,605] [main] [CloudManager:init:280]: Insufficient privileges.Missing Permissions for: s3:*, ec2:*, cloudwatch:*, cloudformation:*, rds:*, sqs:*, ses:SendEmail, ses:SendRawEmail, ses:Verify*. java.lang.RuntimeException: Insufficient privileges.Missing Permissions for: s3:*, ec2:*, cloudwatch:*, cloudformation:*, rds:*, sqs:*, ses:SendEmail, ses:SendRawEmail, ses:Verify*.
Riešenie
As a workaround, configure SCP account so that it does not restrict the role being used to deploy CDRS.
Dotknuté produkty
Avamar, PowerProtect Data Protection Appliance, Cloud Disaster Recovery, PowerProtect SoftwareVlastnosti článku
Číslo článku: 000183021
Typ článku: Solution
Dátum poslednej úpravy: 08 máj 2026
Verzia: 7
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.