RHEL: Erros ao importar chave Dell do linux.dell.com para o Red Hat Enterprise Linux 9 com "O algoritmo de hash SHA1 não está disponível"

Zhrnutie: Importar a chave Dell assinada pela "PG Hypervisor Engineering" para o Red Hat Enterprise Linux 9 causará o erro "Assinatura não compatível". Essa chave é usada apenas para VMware sem falhas e não é necessária para nenhuma outra versão do Linux. ...

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

A importação de uma chave pública específica da Dell no Red Hat Enterprise Linux versão 9 falha enquanto

rpm -I https://linux.dell.com/files/pgp_pubkeys/0x274E9C32857A9594.asc

warning: Signature not supported. Hash algorithm SHA1 not available.


Esse erro também poderá ocorrer se essa chave for adicionada ao arquivo de configuração yum.repos.d para uma cópia local do repositório do Dell Update Package (DUP) e do OpenManage Server Administrator (OMSA).

Príčina

Por padrão, o Red Hat Enterprise Linux 9 rejeita a importação de chaves exclusivamente usando hash SHA1 preexistente.

Riešenie

Essa chave específica com o nome de arquivo 0x274E9C32857A9594.asc só é usada pela Dell para assinar dois catálogos DUP usados exclusivamente para configurações do VMware ESXi e vSAN. Ao contrário das outras chaves publicadas publicamente no https://linux.dell.com/files/pgp_pubkeys/, essa chave não deve ser usada ou importada para nenhuma outra versão do Linux. Ele também pode ser removido como uma chave GPG (GNU Privacy Guard) em qualquer arquivo de configuração /etc/yum.repos.d/. Todas as outras chaves são assinadas com hashes SHA2 e SHA512 aceitáveis pelas políticas de segurança do Red Hat Enterprise Linux 9.

Dotknuté produkty

OpenManage Server Administrator
Vlastnosti článku
Číslo článku: 000217148
Typ článku: Solution
Dátum poslednej úpravy: 21 apr 2025
Verzia:  3
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.