SyncIQ misslyckas med felet: Stöd för maximal längd på filnamn varierar

Zhrnutie: Ett SyncIQ-jobb misslyckas när stöd för långt filnamn (LFN) är aktiverat i ett käll- eller målkluster men inte aktiverat i peer-klustret.

Tento článok sa vzťahuje na Tento článok sa nevzťahuje na Tento článok nie je viazaný na žiadny konkrétny produkt. V tomto článku nie sú uvedené všetky verzie produktov.

Symptómy

SyncIQ misslyckas med felet: "Maximum file name length support differs between the source and target. Cannot sync a cluster with long file names to a target cluster without long name support enabled"

Príčina

Ett SyncIQ-jobb misslyckas om LFN är aktiverat på endast ett kluster, källa eller mål i en SyncIQ-relation.
I OneFS är standardvärdet för namnlängd 255 byte och 255 tecken. Båda klustren i en SyncIQ-relation måste ha stöd för långa filnamn (LFN) som överskrider standardvärdet.

Riešenie

Kontrollera om LFN är aktiverat på både käll- och målkluster:

Obs! Om den är aktiverad är den inte reversibel.

 

# isi_for_array -s 'sysctl efs.bam.long_file_name_enabled'

Kontrollera LFN-inställningen för SyncIQ:s käll- och målsökvägar:

# isi sync policies view <policy_name> |grep Path:
# isi namelength list

Aktivera LFN i klustret:

Obs! Om den är aktiverad är den inte reversibel.
 
# isi_sysctl_cluster efs.bam.long_file_name_enabled=1 --explanation="Enable LFN"

 

Obs! Ibland kan det också krävas en inställning för matchande namnlängd för att spegla källinställningen.


Exempelkommando:

 

# isi namelength create --max-bytes xxxx --max-chars xxxx /ifs/<lfn_path>

Ďalšie informácie

LFN introducerades i OneFS 9.3.
Mer information: http://www.unstructureddatatips.com/onefs-and-long-filenames/Den här hyperlänken tar dig till en webbplats utanför Dell Technologies.

Dotknuté produkty

Isilon SyncIQ

Produkty

PowerScale
Vlastnosti článku
Číslo článku: 000343370
Typ článku: Solution
Dátum poslednej úpravy: 12 nov 2025
Verzia:  2
Nájdite odpovede na svoje otázky od ostatných používateľov spoločnosti Dell
Služby podpory
Skontrolujte, či sa na vaše zariadenie vzťahujú služby podpory.