OneFS:事件通知:节点达到根文件系统上 95% 或以上的已用容量

摘要: 在较旧的 Isilon IQ X 和 NL 系列节点上,根 (/) 目录的最大大小为 500 MB,并显示 95% 或更大的已用容量。即使没有安装任何额外的用户文件或固件程序包,也会发生这种情况。较新的节点具有大小为 1 GB 的根目录,通常显示 49% 的已用容量。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

     

    事件

    Node reached 95% used capacity on the root file system.

    -或-

    The root partition is near capacity.

    Event ID: 100010003

    原因

    详细信息

    此事件表示一个或多个节点上的根分区接近满容量。

    发生此事件的原因可能有多种。两个最常见的原因是:

    • 用户将文件移动到未指定的根目录,而不是 /ifs 目录。
    • 节点固件已升级,但固件程序包未删除。

    解决方案

    响应

    使用以下一个或多个过程对此警报的原因进行故障处理。
     

    重要!

    当根分区已满或接近容量时,请勿删除或安装任何软件修补程序。在根分区已满时尝试安装/删除修补程序可能会导致修补程序安装或删除过程失败。如果在具有完整根分区的群集上,安装或删除过程失败,这可能会阻止回滚到以前的系统配置。这种情况可能会使群集处于不稳定或不可访问的状态。


    有关在 Isilon 群集上维护足够可用空间的更多信息,请参阅戴尔在线支持网站上的 群集容量管理指南


    阶段 1:删除不属于根 (/) 目录的文件。

    1. 检查警报消息以确定受影响的文件系统。该消息标识生成警报的群集和节点(按节点编号)。该消息还将受影响的文件系统标识为以下之一:ifsvar、崩溃或
    2. 在生成警报的节点上,运行以下命令以列出 目录中大于 5 MB 的所有文件:
       
      find -x / -type f -size +10000 -exec ls -lh {} \; | awk '{ print $9 ": " $5 }'

      将显示类似以下内容的输出:
       
      /boot/kernel.amd64/efs.ko: 10M
      /usr/libexec/cc1: 6.6M
      /usr/libexec/cc1plus: 7.2M
      /usr/libexec/cc1obj: 6.6M
      /usr/local/lib/libxerces-c-3.1.so: 5.6M
      /usr/local/lib/libxerces-c.so: 5.6M
      /usr/local/sbin/nmbd: 9.9M
      /usr/local/connectemc/connectemc: 15M
      /usr/local/aspera/sbin/asperacentral: 5.0M

      上面的示例输出列出了通常位于 目录中的文件。不应删除这些文件。
       
    3. 在输出中,查找通常不属于根目录的任何文件。例如,OneFS 安装程序文件、日志收集或用户创建的文件。(请参阅上一步中的示例输出,了解属于根目录且不应删除的文件。)
    4. 删除文件或将其移至 /ifs 目录。如果您不确定要移除哪些文件,请联系 Isilon 技术支持部门寻求帮助。

      运行以下命令以确认根 (/) 目录低于警报阈值:
       
      isi_for_array -s 'df -h /'

      将显示类似以下内容的输出:
       
      Filesystem     Size    Used   Avail Capacity  Mounted on
      /dev/imdd0a    496M    445M     11M    94%    /
    5. 清除所有现有警报:
       
      isi event bulk --resolved=true   (OneFS 8.0 or newer)
      -or-
      isi events cancel all            (OneFS 7.x or older)
      
      
       
    6. 如果在删除任何大文件后未回收空间,请查找文件仍处于打开状态的进程。必须停止该过程才能关闭保存空间的文件句柄。请参阅文章 322712如何使用 fstat 命令列出节点上的打开文件
    7. 如果问题仍未解决,请转至第 2 阶段。



    阶段 2:删除 Isilon 节点固件程序包。

    Isilon 节点固件程序包附带的说明包括在安装固件后删除固件程序包的步骤。如果未完成该步骤,则可能会导致 目录超出容量。

    1. 运行以下命令以确认群集上已安装固件程序包:
       
      isi upgrade patches list     (OneFS 8.0 or newer)
      -or-
      isi pkg info                 (OneFS 7.x or older)

      将显示类似以下内容的输出:
       
      IsiFw_Package_v8.2:
      Isilon firmware packages contain firmware images that may be used to
      update certain devices in your cluster. To install this firmware package,
      use the 'isi pkg install <package-filename>' command. Note that
      the act of installing the package will not automatically update your
      devices. Once installed, please refer to 'isi firmware --help' or the
      firmware section in 'man isi' for more information.
       
    2. 删除固件升级包,其中 <package-filename> 或 <patch>  是固件程序包文件名的名称:
       
      isi upgrade patches uninstall --patch=<patch>  (OneFS 8.0 or newer)
      -or-
      isi pkg delete <package-filename>              (OneFS 7.x or older)
       
    3. 运行以下命令以确认 目录低于警报阈值:
       
      isi_for_array -s 'df -h /'

      将显示类似以下内容的输出:
       
      mycluster-1: Filesystem Size Used Avail Capacity Mounted on
      mycluster-1: /dev/imdd0a 496M 445M 11M 97% /
      mycluster-2: Filesystem Size Used Avail Capacity Mounted on
      mycluster-2: /dev/imdd0a 496M 445M 12M 97% /
      mycluster-3: Filesystem Size Used Avail Capacity Mounted on
      mycluster-3: /dev/imdd0a 496M 445M 12M 97% /
       
    4. 清除所有现有警报:
      isi event bulk --resolved=true   (OneFS 8.0 or newer)
      -or-
      isi events cancel all            (OneFS 7.x or older)
      
       
    5. 如果问题仍未解决,请转至第 3 阶段。



    阶段 3:联系 Isilon 技术支持

    如果无法确定根 (/) 目录接近或高于容量的原因,请执行以下作:

    1. 通过运行以下命令收集系统日志:
       
      isi_gather_info -s 'ls -lhat /' -s 'du -axh / | sort -rn' -s 'du -xhd1 /'

      日志将自动上传到戴尔技术支持。
       
    2. 请联系 戴尔技术支持 以帮助对问题进行故障处理。

    受影响的产品

    PowerScale OneFS

    产品

    Isilon, PowerScale OneFS
    文章属性
    文章编号: 000016965
    文章类型: Solution
    上次修改时间: 26 6月 2025
    版本:  4
    从其他戴尔用户那里查找问题的答案
    支持服务
    检查您的设备是否在支持服务涵盖的范围内。