NMC 报告无法生成,错误“Connection Refused.检查主机名和端口是否正确,并且端口主机接受 TCP/IP 连接“ 出现

摘要: 您正在尝试在 NetWorker Management Console (NMC) 中生成报告,并接收以下内容:“连接被拒绝。检查主机名和端口是否正确,并且端口主机接受 TCP/IP 连接”。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

您正在尝试在 NetWorker Management Console (NMC) 中生成报告,并接收以下内容:
“连接被拒绝。检查主机名和端口是否正确,并且端口主机接受 TCP/IP 连接”
kA2f1000000K6b7CAC_3_0
 

原因

端口 5432 未打开或在 NMC 客户端与 NetWorker/NMC 服务器之间被阻止。

解决方案

1.在 NMC 服务器上,确认端口 5432 正在侦听:
Linux: netstat -anop | grep 5432
Windows: netstat -ao | findstr 5432
C:\Windows\system32>netstat -ao | findstr 5432
  TCP    0.0.0.0:5432           WINSRVR2K16:0          LISTENING       2836
  TCP    127.x.x.1:5432         WINSRVR2K16:49380      ESTABLISHED     2836
  TCP    127.x.x.1:49380        WINSRVR2K16:5432       ESTABLISHED     3556
  TCP    [::]:5432              WINSRVR2K16:0          LISTENING       2836
  UDP    127.x.x.1:65432        *:*                                    724
2.在 NMC 客户端上,确认端口 5432 可在 NMC 服务器主机上访问:
语法: nsrports -t NMC_Server_Hostname -p 5432
C:\Users\Administrator>nsrports -t winsrvr2k16 -p 5432
Forward lookup for winsrvr2k16
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k16.lab.emc.com
Address (A):             192.xxx.xx.xx
Connect to port 5432:    . . . . . . * 
A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.


Reverse lookup for 192.xxx.xx.xx
Query time:              0.003 sec
Name:                    winsrvr2k16.lab.emc.com

3.确认没有操作系统或网络防火墙阻止端口 5432,打开上述命令后应成功:
C:\Users\Administrator>nsrports -t winsrvr2k16 -p 5432
Forward lookup for winsrvr2k16
Query time:              0.001 sec
Canonical name (CNAME):  winsrvr2k16.lab.emc.com
Address (A):             192.xxx.xx.xx
Connect to port 5432:    Succeeded (0.007 sec)

Reverse lookup for 192.xxx.xx.xx
Query time:              0.000 sec
Name:                    winsrvr2k16.lab.emc.com

其他信息

受影响的产品

NetWorker

产品

NetWorker
文章属性
文章编号: 000038109
文章类型: Solution
上次修改时间: 06 11月 2025
版本:  6
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。