Avamar – Säkerhetskopiering av en datauppsättning som innehåller många trasiga symboliska länkar löper långsamt

摘要: Avamar-säkerhetskopiering av datauppsättning som innehåller många trasiga symboliska länkar löper långsamt.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

En Avamar-säkerhetskopiering av en datauppsättning som innehåller många symboliska länkar körs långsamt.

Det finns många poster i säkerhetskopieringsloggen som visar att vi säkerhetskopierar symboliska länkar.

2014-10-21 21:26:35 avtar Info <16280>: Not traversing 'E:\folder\folder\

folder\folder\folder\folder\someotherfile.zip' since it's a 'REPARSE_USER_SYMLINK_FILE' and 'dereference' flag not specified

 

Loggningsposter visar att symboliska länkar kan ha skadats.

2014/10/21-15:50:34.96600 [avtar]  GetReparsePointInfo() 'E:\folder\folder\folder\folder\folder\folder\folder\folder\folder\file.exe' does not have a resolveable target

 

原因

Data fanns tidigare på en annan enhet som hade bytts ut och omkonfigurerats.

Säkerhetskopieringsdatauppsättningen innehöll en katalog som innehöll över en halv miljon symboliska länkar.
När avtar detekterar en länk som trasig rapporterar den "does not have a resolveable target".
I det här scenariot uppstod beteendet eftersom
enheten nyligen hade omkonfigurerats

Åtgärden att kontrollera en symbolisk länk och se att den är trasig innebär en lång fördröjning. Säkerhetskopieringen tog cirka 9 timmar längre än normalt vid försök att skanna dessa (en halv miljon) trasiga symlinks.

Det verkar ha inträffat även om säkerhetskopieringen inte konfigurerades med --avreference.
Avreferensflaggan instruerar avtar att säkerhetskopiera målet för en symbolisk länk.
 
 -dereference. 2014/10/21-15:50:15.90899 [avtar] --dereference NOT specified, not adding any Cross-Volume Symlinks to freeze volumes list.

解决方案

Mappen som innehåller de trasiga symlinks (~0,6 miljoner) exkluderades från säkerhetskopieringen.  

Slutförandetiden minskades från 11 timmar till cirka 2 timmar.

受影响的产品

Avamar

产品

Avamar, Avamar Client
文章属性
文章编号: 000041052
文章类型: Solution
上次修改时间: 26 3月 2024
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。