DPA: Der auf NetWorker installierte DPA-Agent ist nicht beim DPA-Anwendungsserver registriert
摘要: In diesem Artikel wird die Problemumgehung für den Fall erläutert, dass der auf NetWorker installierte DPA-Agent nicht beim DPA-Anwendungsserver registriert ist.
症状
Der DPA-Agent ist lokal auf dem NetWorker-Server installiert, wird jedoch nicht beim DPA-Anwendungsserver registriert. Agent-Protokolle haben die folgenden Fehlermeldungen.
ERR 5508.7112 20160530:160845 agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...
WARN 5508.7112 20160530:161118 agent.config - registerAgentProcess(): Missing result in NULL
Die Kommunikation zwischen dem DPA-Anwendungsserver und dem DPA-Agent funktioniert einwandfrei. Anpingen nslookup von der Anwendung zum Agenten und funktioniert umgekehrt einwandfrei.
Versetzen Sie den Agenten manuell in den Debug-Modus und greifen Sie auf die Debug-Protokolle zu, während der Agent versucht, sich beim App-Server zu registrieren. Überprüfung der Protokolle ergab, dass eine Hardwarefirewall (Internet-Proxy) vorhanden war.
<td class="contentData"> You must be authenticated to access this URL. </td> </tr> <a href="http://******************/Information%20Security%20Noticeboard/Information%20Security%20Policies%20and%20Procedures/IMS-ITM-PY-00005%20(Internet%20Use%20Policy)-V5.0.pdf">******** Internet Browsing Policy Click here for review</a> </td> </tr> <td class='helpDeskData' background='/mwg-internal/de5fs23hu73ds/files/default/img/bg_navbar.jpg'> For assistance, please contact your system administrator. </td> </tr> <td class='footData'> generated <span id="time">2016-05-30 16:22:05</span> by New ****** Web Gateway <br />
原因
Dies ist ein Umweltproblem. DPA funktioniert wie vorgesehen.
Um festzustellen, ob ein Proxy konfiguriert ist, öffnen Sie die Eingabeaufforderung mit Administratorrechten und führen Sie den folgenden Befehl aus: "netsh winhttp show proxy“ geändert.
Wenn der Proxyserver nicht konfiguriert ist, wird die Ausgabe wie im folgenden Screenshot angezeigt:
解决方案
Wenden Sie sich an den lokalen System- oder Netzwerkadministrator, um die Regeln und Parameter zu ändern, die für die Firewall- oder Proxyeinstellungen konfiguriert sind, um die Kommunikation vom DPA-Agent-Server zum Anwendungsserver zu ermöglichen.
Eine weitere Problemumgehung, die angewendet werden kann, besteht darin, die auf dem Server konfigurierten Proxyeinstellungen zu entfernen. Führen Sie die folgenden Schritte aus, um die Proxyservereinstellungen zu entfernen:
- Beenden Sie die Agent-Services auf dem Server.
- Öffnen Sie die Eingabeaufforderung mit Administratorrechten.
- Führen Sie den Befehl "
netsh winhttp show proxy", um erneut zu überprüfen, ob der Proxyserver aufgeführt ist oder nicht. - Falls aufgeführt, führen Sie den Befehl "
netsh winhttp reset proxy“ geändert. Dadurch werden die auf dem Server konfigurierten Proxy-Einstellungen entfernt. - Starten Sie den Agent-Service erneut und überprüfen Sie in den Agent-Protokollen, ob er erfolgreich beim DPA-Anwendungsserver registriert wurde.
Wenn das Problem durch die oben genannten Schritte nicht behoben wurde. Wenden Sie sich an den technischen Support von EMC, um Unterstützung zu erhalten