DPA: O agente do DPA instalado no NetWorker não está registrado no servidor de aplicativos do DPA
摘要: Este artigo explica a solução temporária quando o agente do DPA instalado no NetWorker não está registrado no servidor de aplicativos do DPA.
症状
O agente do DPA é instalado localmente no servidor do NetWorker, mas não está registrado no servidor do aplicativo do DPA. Os logs do agente têm as seguintes mensagens de erro.
ERR 5508.7112 20160530:160845 agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...
WARN 5508.7112 20160530:161118 agent.config - registerAgentProcess(): Missing result in NULL
A comunicação do servidor do aplicativo do DPA e do agente do DPA está funcionando bem. Ping nslookup do aplicativo para o agente e, inversamente, funciona bem.
Coloque manualmente o agente no modo de depuração e obtenha os registros de depuração enquanto o agente tenta se registrar no servidor do aplicativo. Analise os logs e descobriu que havia um firewall de hardware (proxy da Internet) presente.
<td class="contentData"> You must be authenticated to access this URL. </td> </tr> <a href="http://******************/Information%20Security%20Noticeboard/Information%20Security%20Policies%20and%20Procedures/IMS-ITM-PY-00005%20(Internet%20Use%20Policy)-V5.0.pdf">******** Internet Browsing Policy Click here for review</a> </td> </tr> <td class='helpDeskData' background='/mwg-internal/de5fs23hu73ds/files/default/img/bg_navbar.jpg'> For assistance, please contact your system administrator. </td> </tr> <td class='footData'> generated <span id="time">2016-05-30 16:22:05</span> by New ****** Web Gateway <br />
原因
Essa é uma questão ambiental. O DPA está funcionando conforme projetado.
Para identificar se um proxy está configurado, abra o prompt de comando com privilégios administrativos e execute o seguinte comando "netsh winhttp show proxy."
Se o servidor proxy não estiver configurado, a saída será mostrada como na captura de tela abaixo:
解决方案
Envolva o sistema local ou o administrador de rede para modificar as regras e os parâmetros configurados para as configurações de firewall ou proxy para permitir a comunicação do servidor do DPA Agent com o servidor de aplicativos.
Outra solução temporária que pode ser aplicada é remover as configurações de proxy definidas no servidor. Siga as etapas abaixo para remover as configurações do servidor proxy:
- Interrompa os serviços do agente no servidor.
- Abra o prompt de comando com privilégios administrativos.
- Execute o comando "
netsh winhttp show proxy" para verificar novamente se o servidor proxy está listado ou não. - Se listado, execute o comando "
netsh winhttp reset proxy." Isso remove as configurações de proxy definidas no servidor. - Inicie o serviço do agente novamente e verifique se os logs do agente foram registrados com sucesso no servidor do aplicativo do DPA.
Se as etapas acima não resolverem o problema. Entre em contato com o suporte técnico da EMC para obter assistência