VNX: El comando server_df falla

摘要: VNX: El comando server_df falla

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

El comando 'server_df server_2' falla con "Error 2: server_2 : No such file or directory failed to complete command":

[nasadmin@ssgnas03cs0 ~]$ server_df server_2
server_2 :
Error 2: server_2 : No such file or directory
failed to complete command

Las evaluaciones del estado previas a la actualización fallan con los siguientes errores:

Blades : Check if root filesystem is too large
Error HC_DM_14505148436: Output from command "/nas/bin/server_df
         server_2" has no information on file system root_fs_2

Blades : Check if root filesystem has enough free space
Error HC_DM_14505148440: Output from command "/nas/bin/server_df
         server_2" has no information on file system root_fs_2

Blades : Check if file system usage is under limit
Error HC_DM_14505148563: Could not determine available disk space for
         the mounted file systems on the following Blades:
         * server_2

Todos los demás comandos de server_df funcionan correctamente con otros administradores de transferencia de datos:

[nasadmin@ssgnas03cs0 ~]$ server_df server_3
server_3 :
Filesystem          kbytes         used        avail capacity Mounted on
root_fs_common       15368         5280        10088   34%    /.etc_common
root_fs_3           258128         6184       251944    2%    /

 

原因

La causa raíz en esta instancia fue que el sistema de archivos raíz para server_2 estaba desmontado.

[nasadmin@ssgnas03cs0 ~]$ server_mount ALL
server_2 :
                       <------ nothing mounted
server_3 :
root_fs_3 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

Cuando se enumeran todos los sistemas de archivos, queda claro que el sistema de archivos raíz "root_fs_2" para server_2 aparece como no en uso porque estaba desmontado.

[nasadmin@ssgnas03cs0 ~]$ nas_fs -l
id      inuse type acl   volume    name                server
1         n    1   0     10        root_fs_1
2         y    1   0     40        root_fs_common      3,2
3         n    5   0     73        root_fs_ufslog
4         n    5   0     76        root_panic_reserve
5         n    5   0     93        root_fs_d3
6         n    5   0     94        root_fs_d4
7         n    5   0     95        root_fs_d5
8         n    5   0     96        root_fs_d6
9         n    1   0     12        root_fs_2              <------------ inuse = n
10        y    1   0     14        root_fs_3           2

 

解决方案

Antes de que el cliente solicitara asistencia del servicio de soporte, se completó un reinicio del administrador de transferencia de datos y no se observó ninguna mejora. Para resolver este problema, inicie sesión como usuario "raíz" en la Control Station primaria y vuelva a montar el sistema de archivos "root_fs_2" en el administrador de transferencia de datos server_2:

[root@ssgnas03cs0 nasadmin]# server_mount server_2 root_fs_2 /
server_2 : done

Asegúrese de que el sistema de archivos raíz se vuelva a montar:

[root@ssgnas03cs0 nasadmin]# server_mount ALL
server_2 :
root_fs_2 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

server_3 :
root_fs_3 on / uxfs,perm,rw
root_fs_common on /.etc_common uxfs,perm,ro

Después de montar el sistema de archivos raíz, ejecute el comando "server_df server_2" para asegurarse de que se complete correctamente:

[root@ssgnas03cs0 nasadmin]# server_df server_2
server_2 :
Filesystem          kbytes         used        avail capacity Mounted on
root_fs_common       15368         5280        10088   34%    /.etc_common
root_fs_2           258128         6264       251864    2%    /

 

其他信息

En esta instancia en particular, el cliente estaba realizando una limpieza de sistemas de archivos innecesarios a fin de recuperar espacio para el pool NAS. Como parte de la limpieza, se desmontaron de forma permanente e intentaron eliminar el sistema de archivos raíz "root_fs_2" para el administrador de transferencia de datos server_2. El sistema de archivos raíz de un administrador de transferencia de datos nunca se debe eliminar.

 

受影响的产品

VNX2 Series

产品

Celerra, VNX1 Series, VNX2 Series
文章属性
文章编号: 000056821
文章类型: Solution
上次修改时间: 20 10月 2025
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。