Dell EMC Unity: uDoctors planlagte opgaver forårsager høj CPU-udnyttelse (kan rettes af brugeren)
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
Hver dag på samme tidspunkt stiger udnyttelsen på den primære storageprocessor til 90-100 % og forbliver på dette niveau i ca. 15 minutter.
原因
CloudIQ-teamet har fundet et specifikt plug-in til indsamling af servicedata, som nogle gange kan udløse flere PSQL-kommandoer.
Når det sker, vil PSQL-forespørgslerne forårsage en omfattende CPU-udnyttelse af den primære storageprocessor, som er den SP, der er ansvarlig for at køre uDoctor.
Bemærk: Dette sker ikke, når du opretter og foretager servicedataindsamlingen manuelt, hvilket kun påvirker uDoctors planlagte opgaver såsom dem fra daglige logfiler, der genereres til CloudIQ.
Når det sker, vil PSQL-forespørgslerne forårsage en omfattende CPU-udnyttelse af den primære storageprocessor, som er den SP, der er ansvarlig for at køre uDoctor.
Bemærk: Dette sker ikke, når du opretter og foretager servicedataindsamlingen manuelt, hvilket kun påvirker uDoctors planlagte opgaver såsom dem fra daglige logfiler, der genereres til CloudIQ.
解决方案
Løsningen på dette problem er allerede på plads og vil blive inkluderet i den næste Unity OE-udgivelse version 5.0.3.
Du kan finde flere oplysninger om Dell EMC Unity OE-versioner og deres udgivelse i artikelnummer 000489694.
Der findes også en løsning, der kan anvendes til at omgå problemet, indtil koden frigives.
Hvis du vil have hjælp til at gennemføre denne løsning, skal du tilgå support- og referenceartikel nummer 000541286.
Du kan finde flere oplysninger om Dell EMC Unity OE-versioner og deres udgivelse i artikelnummer 000489694.
Der findes også en løsning, der kan anvendes til at omgå problemet, indtil koden frigives.
Hvis du vil have hjælp til at gennemføre denne løsning, skal du tilgå support- og referenceartikel nummer 000541286.
其他信息
For at bekræfte, at det er dette problem, som du oplever, skal du bruge nedenstående kommandoer i Unisphere CLI på en SSH-terminal efter eget valg:
On EMCSystemLogFile.log
UEMCLI Metrics command (historisk):
UEMCLI Metrics command (realtid):
On EMCSystemLogFile.log
service@spb:~# tailf 00_emc_backend_log_shared/EMCSystemLogFile.log | grep -i udoctor
"2020-02-16T13:03:12.155Z""Array_spb@Serial_Number""Kittyhawk_safe""9134""unix/spb/root""INFO""1:115000d" :: "Internal Information only. PSM File "udoctor" Deleted." :: Category=System Component=psm TimeZone=UTC
"2020-02-17T13:03:12.944Z""Array_spb@Serial_Number""Kittyhawk_safe""9134""unix/spb/root""INFO""1:115000d" :: "Internal Information only. PSM File "udoctor" Deleted." :: Category=System Component=psm TimeZone=UTC
"2020-02-16T13:03:12.155Z""Array_spb@Serial_Number""Kittyhawk_safe""9134""unix/spb/root""INFO""1:115000d" :: "Internal Information only. PSM File "udoctor" Deleted." :: Category=System Component=psm TimeZone=UTC
"2020-02-17T13:03:12.944Z""Array_spb@Serial_Number""Kittyhawk_safe""9134""unix/spb/root""INFO""1:115000d" :: "Internal Information only. PSM File "udoctor" Deleted." :: Category=System Component=psm TimeZone=UTC
UEMCLI Metrics command (historisk):
service@spb:~# uemcli -no /metrics/value/hist -path sp.*.cpu.summary.utilization show -interval 60 -from "2020-02-16 12:59:00" -to "2020-02-16 13:59:00"
Timestamp |SP |summary
| |CPU
| |Util %
--------------------+----------+-------
2020-02-16 13:02:00 |spa | 13.93
|spb | 66.47
2020-02-16 13:03:00 |spa | 12.49
|spb | 90.96
2020-02-16 13:04:00 |spa | 12.94
|spb | 92.63
2020-02-16 13:05:00 |spa | 11.91
|spb | 93.29
2020-02-16 13:06:00 |spa | 5.072
|spb | 92.28
2020-02-16 13:07:00 |spa | 2.497
|spb | 90.06
2020-02-16 13:08:00 |spa | 2.452
|spb | 92.38
2020-02-16 13:09:00 |spa | 2.527
|spb | 95.68
2020-02-16 13:10:00 |spa | 2.441
|spb | 98.36
2020-02-16 13:11:00 |spa | 2.845
|spb | 97.170
2020-02-16 13:12:00 |spa | 2.466
|spb | 97.096
2020-02-16 13:13:00 |spa | 2.479
|spb | 97.732
2020-02-16 13:14:00 |spa | 2.469
|spb | 98.023
2020-02-16 13:15:00 |spa | 2.362
|spb | 96.391
2020-02-16 13:16:00 |spa | 2.697
|spb | 65.053
Timestamp |SP |summary
| |CPU
| |Util %
--------------------+----------+-------
2020-02-16 13:02:00 |spa | 13.93
|spb | 66.47
2020-02-16 13:03:00 |spa | 12.49
|spb | 90.96
2020-02-16 13:04:00 |spa | 12.94
|spb | 92.63
2020-02-16 13:05:00 |spa | 11.91
|spb | 93.29
2020-02-16 13:06:00 |spa | 5.072
|spb | 92.28
2020-02-16 13:07:00 |spa | 2.497
|spb | 90.06
2020-02-16 13:08:00 |spa | 2.452
|spb | 92.38
2020-02-16 13:09:00 |spa | 2.527
|spb | 95.68
2020-02-16 13:10:00 |spa | 2.441
|spb | 98.36
2020-02-16 13:11:00 |spa | 2.845
|spb | 97.170
2020-02-16 13:12:00 |spa | 2.466
|spb | 97.096
2020-02-16 13:13:00 |spa | 2.479
|spb | 97.732
2020-02-16 13:14:00 |spa | 2.469
|spb | 98.023
2020-02-16 13:15:00 |spa | 2.362
|spb | 96.391
2020-02-16 13:16:00 |spa | 2.697
|spb | 65.053
UEMCLI Metrics command (realtid):
service@spb:~# uemcli -no /metrics/value/rt -path sp.*.cpu.summary.utilization show -interval 10
Timestamp |SP |summary
| |CPU
| |Util %
--------------------+----------+-------
2020-02-17 13:03:20 |spa | 0.929
|spb | 90.810
2020-02-17 13:03:30 |spa | 1.928
|spb | 90.980
2020-02-17 13:03:40 |spa | 2.417
|spb | 90.537
2020-02-17 13:03:50 |spa | 1.912
|spb | 91.601
2020-02-17 13:04:00 |spa | 2.124
|spb | 93.625
2020-02-17 13:04:10 |spa | 3.828
|spb | 92.191
Timestamp |SP |summary
| |CPU
| |Util %
--------------------+----------+-------
2020-02-17 13:03:20 |spa | 0.929
|spb | 90.810
2020-02-17 13:03:30 |spa | 1.928
|spb | 90.980
2020-02-17 13:03:40 |spa | 2.417
|spb | 90.537
2020-02-17 13:03:50 |spa | 1.912
|spb | 91.601
2020-02-17 13:04:00 |spa | 2.124
|spb | 93.625
2020-02-17 13:04:10 |spa | 3.828
|spb | 92.191
受影响的产品
Dell EMC Unity Family产品
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 350F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 450F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 550F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity 650F
, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family, Dell EMC Unity Hybrid
...
文章属性
文章编号: 000058581
文章类型: Solution
上次修改时间: 20 10月 2025
版本: 4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。