PowerScale: Isilon: Användning av sudo-kontot efter uppgraderingen misslyckas med "ANVÄNDAREN finns inte i sudoers-filen. Denna händelse är rapporterad." (kan korrigeras av användaren)

摘要: Sudo-konton i ett begränsat antal OneFS-versioner skapades med hjälp av en lösning. När klustret uppgraderas till en OneFS-kodversion där problemet åtgärdades fungerar inte dessa sudo-konton korrekt. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Koden uppgraderades från en version av OneFS där isi_visudo fungerade inte mot en nyare version av OneFS där isi_visudo åtgärdades.

sudo konton som upprättats på en OneFS-version med en defekt isi_visudo upplevt fel med sudo efter uppgradering till en korrigerad kodversion (t.ex. v8.1.0.4). Trots sudo Kontoposter som bekräftas i /etc/mcp/override/sudoers och /usr/local/etc/sudoers—som kräver root Tillträde—sudo inte fungerade som den skulle.

Mer utdata från det icke-fungerande sudo-kontot kan se ut som följande utdata, förutom USERNAME is not in the sudoers file fel:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

原因

Problemet är relaterat till OneFS-koden.

解决方案

Logga in som root användare, och:

  1. Använd
    isi_visudo
    och ta bort ANVÄNDARKONTOT som har ställts in för sudo. Var noga med att bara ta bort sudo konto som inte fungerar. Spara filen. 
    :wq!
  2. Använd
    isi_visudo
    och återskapa ANVÄNDARKONTOT med rätt inställningar. Spara filen.

Koduppgraderingen bör inte påverka rollerna och andra auktoriseringar. Användarkontot och lösenordet förblir oförändrade. När du har utfört stegen ovan kommer kontot att fungera igen.

受影响的产品

Isilon

产品

Isilon, PowerScale OneFS
文章属性
文章编号: 000059475
文章类型: Solution
上次修改时间: 01 4月 2025
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。