PowerScale: Isilon: Bruk av sudo-konto etter oppgradering mislykkes med "BRUKEREN er ikke i sudoers-filen. Denne hendelsen er anmeldt.» (Kan rettes opp av bruker)

摘要: Sudo-kontoer i et begrenset antall OneFS-versjoner ble opprettet ved hjelp av en midlertidig løsning. Når klyngen oppgraderes til en OneFS-kodeversjon der problemet ble løst, fungerer ikke disse sudokontoene som de skal. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Koden ble oppgradert fra en versjon av OneFS der isi_visudo ikke fungerte til en nyere versjon av OneFS der isi_visudo ble fikset.

sudo kontoer opprettet på en OneFS-versjon med en defekt isi_visudo opplevde feil med sudo etter oppgradering til en korrigert kodeversjon (for eksempel v8.1.0.4). Tross sudo Kontooppføringer bekreftes i /etc/mcp/override/sudoers og /usr/local/etc/sudoers– som krever root tilgang—sudo fungerte ikke som den skulle.

Mer utdata fra den ikke-fungerende sudo-kontoen kan se ut som følgende utdata, i tillegg til USERNAME is not in the sudoers file feil:

MYCLUSTER-13% sudo isi status
We trust you have received the usual lecture from the local System
Administrator. It usually boils down to these three things:
    #1) Respect the privacy of others.
    #2) Think before you type.
    #3) With great power comes great responsibility.
Password:
Sorry, user USERNAME is not allowed to execute '/usr/bin/isi status' as root on mycluster-13.

原因

Problemet er relatert til OneFS-koden.

解决方案

Logg på som root bruker, og:

  1. Bruk
    isi_visudo
    og slette BRUKERKONTOEN som ble satt opp for sudo. Vær forsiktig bare for å slette sudo konto som ikke fungerer. Lagre filen. 
    :wq!
  2. Bruk
    isi_visudo
    og gjenopprett BRUKERKONTOEN med de riktige innstillingene. Lagre filen.

Kodeoppgraderingen skal ikke påvirke rollene og andre autorisasjoner. Brukerkontoen og passordet forblir uendret. Etter å ha utført trinnene ovenfor, vil kontoen fungere igjen.

受影响的产品

Isilon

产品

Isilon, PowerScale OneFS
文章属性
文章编号: 000059475
文章类型: Solution
上次修改时间: 01 4月 2025
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。