Kan ikke afinstallere PowerPath ved Sun Solaris-værtsfejl = enheden er optaget

摘要: Kan ikke afinstallere PowerPath ved Sun Solaris-værtsfejl = enheden er optaget

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

pkgrm EMCpower

Kan ikke afinstallere PowerPath ved Sun Solaris-værtsfejl = enheden er optaget

pkgrm kunne ikke installere PowerPath på Sun Solaris 
Fejl på PowerPath Pseudos optaget eller monteret. Stop alle I/O'er, og sørg for, at alle diskenheder ikke* er monteret, og prøv derefter at fjerne pakken.

原因

----------------------------------------------------------------
* Fjernelse af EMCpower:
* Fejl: PowerPath-pseudo(er), der stadig er i brug, optaget eller monteret.
* Stop alle I/O'er, og sørg for, at alle diskenheder ikke
* er monteret, og prøv derefter at fjerne pakken.
----------------------------------------------------------------
pkgrm: FEJL: Scriptet for forudflytning blev ikke fuldført
Fjernelse af <EMCpower> mislykkedes.

解决方案

1.
Kontroller, om pseudo-enhederne stadig er forbundet. Hvis det er tilfældet, skal du afbryde dem og prøve at afinstallere PowerPath.

Hvis problemet fortsætter –

2.
Kontroller ved brug af "fuser -c <pseudo device>" og "fuser -ck <pseudo device>", og prøv at afinstallere PowerPath.

Hvis problemet stadig fortsætter –

3.
Hvis de to ovenstående løsningsforslag ikke virker, skal du genstarte systemet til en enkeltbruger i ikke-klyngetilstand og prøve afinstallere PowerPath.

Hvis problemet stadig fortsætter –

4.
Hvis du stadig får vist "device busy error", skal du åbne /etc/-systemfilen og ændre linjen til "set emcp:bPxEnableInit=0" og genstarte værten tilbage i enkeltbrugertilstand. Værdien "0" vil sikre, at emcp-moduler ikke vil blive indlæst under genstart af PowerPath (modinfo | grep -i emcp).
Efter værten dukker op, skal du forsøge at afinstallere PowerPath.

其他信息

Før du redigerer /etc/system-filen, skal du have en kopi af den oprindelige fil.

受影响的产品

PowerPath for Solaris

产品

PowerPath for Solaris
文章属性
文章编号: 000064215
文章类型: Solution
上次修改时间: 14 8月 2025
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。