Avamar: Det går inte att återställa filer från säkerhetskopiering av virtuell dator med FLR

摘要: Det går inte att återställa filer från säkerhetskopiering av virtuell dator med FLR på grund av att proxyn inte kan lösa DNS-namnet för målservern för säkerhetskopiering.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Ej tillämpligt 

  • Vid sökning bland säkerhetskopieringar av virtuell dator med FLR visas följande felmeddelande:
 
kA23a000000GJ2pCAG_3_0
  • Även om den virtuella dator som vi söker på inte når någon av FLR-gränserna.
  • Om vi kontrollerar FLR-loggar på proxyn kan vi se följande felmeddelanden i filen MountMgr.log som finns i katalogen /usr/local/avamarclient/bin/logs, vilket innebär att proxyn inte kan hämta listan över säkerhetskopior från målservern för säkerhetskopiering (DD) och att den inte finns där:
[MM - DEBUG] TID=140213502355139 MID=30870: sAssetPath = /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149 [MM - DEBUG] TID=140213502355139 MID=30871: sClientId = [MM - DEBUG] TID=140213502355139 MID=30872: sMountedAvFS = /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149/VMFiles [MM - ERROR] TID=140213502355139 MID=30873: HLPR_ListOfDirectories failed for /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149/VMFiles [MM - FUNC] TID=140213502355139 MID=30874: IVmdkManager::GetAllAvailableDiskIndexes LEAVE [MM - ERROR] TID=9923 MID=30875: Unable to find backed up VMDK images for: /mnt/dunion/<vCenter_name>/VirtualMachines/<VM_name_UUID>/by-number/0000149
 
  • Även om det finns säkerhetskopior som vi kan hitta enligt nedan via Avamar-verktygsnoden:
mccli backup show --name=/<vCenter_name>/VirtualMachines/<VM_name_UUID>
0,23000,CLI command completed successfully.
Created             LabelNum Size     Retention Hostname                           Location Consistent Level Tier
------------------- -------- -------- --------- ---------------------------------- -------- ---------------- ------
yyyy-mm-dd hh:mm PM 149      ##.# GB D         <AVAMAR_FQDN>                       Local    file             Active

 
  • Vi kan även se att rätt Avamar-IP redan finns i filen axionifs.cmd som finns i katalogen /usr/local/avamar/var enligt nedan:
--server=xxx.xxx.xxx.xxx
--id=restoreonly
--password=#################################
--fuseoptions='-s -r -f -o allow_other,use_ino'
--primarybackupdir=by-number
--inactivity_timeout=172800
--encrypt=tls
--encrypt-strength=high
(END)

原因

  • Den proxy som används kan inte lösa Data Domain FQDN eller målservern för säkerhetskopiering eftersom felet kan ses i den senaste axonifs_xxxxxxx_xxxx_xxxx_xxxxxxxxxxxx.log som finns i katalogen /usr/local/avamar/var:
     

axionfs Info <10539>: Connecting to Data Domain Server "DD_FQDN"(1) (LSU: avamar-xxxxxxxxxx, User: "ddboost")
[axionfs] netsys::getaddrinfo failed for DD_FQDN: Name or service not known
axionfs Error <10541>: Failed to resolve Data Domain Server name "DD_FQDN" to an IP address. Data Domain login FAILED
axionfs Error <10512>: Problem logging into the DDR server index:1
axionfs Error <11014>: Could not open DDR for /, #146
[axionfs] context::loop: Nothing pending on server, only internal work (pending all=4, ext=0, int=0)
axionfs Warning <19046>: Unable to get ddr_files.xml for clientid <VM_CID> and backupid <backupid>
axionfs Warning <19047>: Unable to retrieve DDR info for 'VMConfiguration'
axionfs Error <41308>: Cannot iterate contents of '': Unable to set location information in direlem_iter for 'VMConfiguration'

解决方案

Gör så här för att lösa problemet:
  • Kontrollera att Avamar-proxyn kan lösa FQDN genom att köra kommandot nedan på proxyn:
  1. nslookup <datadomain_FQDN>
  2. nslookup <datadomain_IP>
  • Om det inte finns några giltiga utdata för datadomain redigerar du filen /etc/resolve.conf på proxyn och lägger till rätt DNS-namn. 
ELLER 
  • Lägg till FQDN och IP för datadomain i filen /etc/hosts för proxyn.

受影响的产品

Avamar

产品

Avamar, Avamar Client for VMware
文章属性
文章编号: 000067854
文章类型: Solution
上次修改时间: 06 11月 2025
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。