How to Manually Set nomodeset Kernel Boot Line Option in Linux
摘要: Resolve graphics-related boot problems with Linux. Learn how to set the GRUB "nomodeset" Ubuntu boot option and use the "nomodeset" kernel boot line for smoother booting.
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
YGeneric Canonical Ubuntu media (some OEM Dell media) or other Linux media does not boot to the live environment or installer as usual and instead the computer may stop responding or get stuck.
The first troubleshooting step that may resolve your boot issue and allow you to install Ubuntu is to disable the intel graphics features by setting the nomodeset option before boot.
You can do this either for one-time booting as shown in Solution 1 or you can also make it permanent as seen in Solution 2.
原因
Note: Solution 1 is good for booting off USB or Install media. Solution 2 is good for making permanent if your OS crashes or stops responding after installing.
解决方案
Solution 1
- With media attached, turn on the computer.
- Watch for the GNU GRUB bootloader screen.
- When you see the option for Ubuntu as shown, press the E key on your keyboard.
- In the editor, use the arrow keys to locate the end of the line that starts with the following. Each bootloader may say something slightly different.
linux /boot/vmlinuz***
- Type the following line option into the end of the line.
nomodeset
- Press CTRL+X keys to boot to the normal installer or live environment like normal.
Solution 2
- Open a terminal and type the following:
sudo gedit /etc/default/grub - Enter your password if prompted.
- Move the cursor to the line that looks like the following:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
- Change that line to match the following:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
(you can also remove quiet and or splash variables to troubleshoot no-boot issues)
- Click Save.
- Close the window.
- In the terminal, type the following and press enter:
sudo update-grub2 - Once complete, reboot your computer with this change made.
其他信息
Out of warranty? No problem. Browse to the Dell.com/support website and enter your Dell Service Tag and view our offers.
NOTE: Offers are only available for US, Canada, UK, France, Germany, and China personal computer customers. Server and Storage not applicable.
文章属性
文章编号: 000123893
文章类型: Solution
上次修改时间: 16 4月 2025
版本: 8
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。