Řešení chyby "No Bootable Device Found ve starším režimu" v počítačích Dell

摘要: Řešení chyby "Nebyla nalezena žádná spouštěcí zařízení" u notebooků a stolních počítačů. Zjistěte, jak vyřešit problém, kdy není k dispozici, rozpoznáno nebo nalezeno spouštěcí zařízení přepnutím do režimu UEFI a přeinstalací systému Windows 10 nebo Linux. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Podle níže uvedených pokynů vyřešte následující chybovou zprávu:

Chyba No boot device Found se zobrazí, když je spouštěcí sekvence nastavena na režim Legacy nebo když je operační systém nainstalován v režimu Legacy.


Chyba „No boot device found“

Po instalaci operačního systému se může zobrazit následující chyba: Nebylo nalezeno žádné spouštěcí zařízení.
K této chybě dochází, když je spouštěcí sekvence systému BIOS zařízení nastavena na režim Legacy.

Chyba „No boot device found“

Pokud je operační systém nainstalován v režimu Legacy, zobrazí se po restartování počítače chybová zpráva. Chybu nelze opravit změnou nastavení systému BIOS zpět na Unified Extensible Firmware Interface (UEFI). Je třeba přeinstalovat operační systém.

Poznámka:
  • Tyto konkrétní počítače Dell podporují pouze operační systémy Windows 10 a vyšší a Linux v režimu spouštění UEFI.
  • Před pokusem o přeinstalaci operačního systému se ujistěte, že je v systému BIOS povolen režim UEFI.
  • Použití optické jednotky k instalaci operačního systému není ve režimu Legacy podporováno, protože v nabídce spouštění není k dispozici možnost optické jednotky.
  • Výše uvedené počítače Dell jsou vybaveny procesorem Coffee Lake 7. generace (a vyšší). Počítače jsou navrženy výhradně pro spouštění v UEFI; Spouštěcí prostředí.
  • V důsledku toho se operační systém nespustí, pokud je v těchto počítačích vybrán režim spouštění Legacy.

原因

V systému BIOS je nastaven nesprávný režim spouštění.

解决方案

Pokud je operační systém nainstalován s rozhraním UEFI před změnou spouštěcí sekvence, lze počítač obnovit změnou spouštěcí sekvence zpět na UEFI.

Pokud je operační systém nainstalován v režimu Legacy, nelze počítač obnovit změnou spouštěcí sekvence zpět na režim UEFI.
Je třeba přeinstalovat operační systém.

Při přeinstalaci systému Windows 10 nebo vyššího postupujte následovně:

  1. Zapněte vypnutý počítač a pomocí klávesy F2 na obrazovce s logem Dell přejděte do nabídky nastavení systému BIOS.
  2. Vyberte možnost Boot sequence a změňte ji z hodnoty Legacy na UEFI . Poté klikněte na tlačítko Apply v pravém dolním rohu obrazovky.
    Změna možnosti Boot List Option z hodnoty Legacy na UEFI v nastavení systému BIOS
  3. Vyberte možnost Advanced Boot Options a zakažte možnost Enable Legacy Option ROMs. Poté klikněte na možnost Apply v pravém dolním rohu obrazovky:
    Možnost Enable Legacy Option ROMs v nastavení systému BIOS
  4. Vyberte možnost Secure Boot –> Secure Boot Enable a změňte nastavení z hodnoty Disabled na Enabled.
  5. Poté klikněte na tlačítko Apply v pravém dolním rohu obrazovky:
    Povolení možnost Secure Boot Enable v systému BIOS
  6. Klikněte na možnost Exit v pravém dolním rohu obrazovky a počkejte, až se počítač restartuje.
  7. Přeinstalujte operační systém Windows 10.

Operační systém Linux nainstalujete takto:

  1. Postupujte podle kroků 1 až 3 výše pro instalaci systému Windows 10 (tyto kroky jsou stejné pro instalaci systému Linux).
  2. Ověřte, zda je možnost Secure Boot > Enable v systému BIOS zakázána :
    Zakázání možnosti Secure Boot Enable v systému BIOS
  3. Vyberte možnost SATA Operation (> Operace SATA) – SATA Operation (Operace SATA) a změňte ji na režim AHCI :
    Povolení možnost SATA AHCI
  4. Klikněte na možnost Exit v pravém dolním rohu a počkejte, až se počítač restartuje.
  5. Přeinstalujte operační systém Linux.

Další informace naleznete v článcích znalostní databáze Dell:

其他信息

受影响的产品

Alienware, Dell Pro All-in-One, Dell Pro Max Micro, Dell Pro Max Slim, Dell Pro Max Tower, Dell Pro Micro, Dell Pro Slim, Dell Pro Tower, Dell Tower, Inspiron, OptiPlex, Vostro, XPS, G Series, G Series, Alienware, Dell Pro, Dell Pro Max , Dell Pro Plus, Dell Pro Premium, Inspiron, Latitude, Dell Pro Rugged, Vostro, XPS, Fixed Workstations, Mobile Workstations, Dell Pro Max Micro XE FCM2250 ...
文章属性
文章编号: 000128655
文章类型: Solution
上次修改时间: 08 12月 2025
版本:  19
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。