Avamar:由于 Avamar Server 时移,HFSCHECK 失败并出现MSG_ERR_ROLLING_CHECK

摘要: 不正确的时间源会导致 Avamar 检查点验证 (hfscheck) 失败。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

主要症状:

 

维护活动(检查点和 hfscheck) 未成功完成。

检查点验证 (hfscheck) 失败并显示MSG_ERR_ROLLING_CHECK。

由于最新的检查点已经过验证,因此无法再次验证。

cplist 命令显示具有未来日期和时间的检查点:

cplist
cp.20201103213238 Wed Nov  3 16:32:38 2020   valid --- del  nodes   1/1 stripes   4779
cp.20201104153925 Thu Nov  4 10:39:25 2020   valid --- ---  nodes   1/1 stripes   4796
cp.20320218180432 Wed Feb 18 12:04:32 2032   valid rol ---  nodes   1/1 stripes   4521
 

尝试手动验证检查点失败:

avmaint hfscheck --checkpoint=cp.20201104153925 --rolling
ERROR: avmaint: hfscheck: server_exception(MSG_ERR_ROLLING_CHECK)
 
 
次要症状:

除了维护错误之外,在将来列出备份时可能会出现次要问题,因此:
  • 预测和报告不正确。
  • 管理控制台服务器 (MCS) UI 信息可能不正确。
  • 某些报告(例如,“Completed Activities - Failed”和“Activity Report”)不正确。
 

在 2019 年运行但报告为 2032 年的备份的示例输出:

mccli backup show --name=/clients/client_name
0,23000,CLI command completed successfully.

Created                       LabelNum Size        Retention
----------------------------- -------- ----------- ---------
2032-02-17 19:01:41 GMT-06:00 15       23875106816 DMY
 

-- 或 MCS 刷新:--

avtar --backups --id=MCUser --ap=<password> --path=/MC_BACKUPS --hfsaddr=<server>--count=26
Date       Time     Seq    Label   Size    Plugin   Working directory    Targets
---------- -------- ------ ------- ------- -------- -------------------- -------------------------
2032-02-15 09:01:05 8373           116436K Linux    /usr/local/avamar    var/mc/server_data/

原因

时间服务器问题导致 Avamar 网格上的时钟重置为 2032。

在此期间进行了检查点验证,现在有一个经过验证的 cp(从 2032 年开始)。

工程团队确认,这是使用不正确的时间源时的预期行为。

提醒:此问题可能会在未来的任何日期发生。

解决方案

警告:

如果发现备份时间有差异(根据上述次要症状),则必须先纠正这些差异。请勿执行本文中的步骤,而是联系 Dell Technologies 技术支持 以获得进一步的帮助。
 

要解决 hfscheck 问题:

1.重置调度程序:

avmaint sched reset --ava 
 

2.停止和启动调度程序:

avmaint sched stop --ava
avmaint sched start --ava
 

3.确立检查点。

4.执行 hfscheck

5.在下一个计划的维护窗口期间监视电网,以验证问题是否已解决。

 

 

受影响的产品

Avamar

产品

Avamar, Avamar Server
文章属性
文章编号: 000163146
文章类型: Solution
上次修改时间: 23 4月 2025
版本:  8
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。