「Avamar:Avamar Serverを既知の制御状態に設定する方法

摘要: この記事では、Avamar Serverを既知の制御状態に設定する方法について説明します。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Avamar Serverには、トラブルシューティングと解決作業に影響を与える可能性のある自動化タスクが多数あります。

この手順では、Avamarをいわゆる「既知の制御状態」にして、予期しないアクティビティや望ましくないアクティビティの発生を防ぐ方法について説明します。

手動および高度なメンテナンス タスクを実行する場合は、以下のチェックリストに従う必要があります。例:
  • ストライプの再構築
  • ノードの再構築中
  • オフライン ノードの再起動
これはチェックリストであり、操作の実行方法や結果の解釈方法に関するガイドではありません。

これはヘルス チェック ソリューション ではありません 。Avamarサーバーが正常ではないことを前提としています。

原因

手動または高度なメンテナンス タスクは、Avamar Serverで実行する必要があります。

解决方案

注意:以下で参照するコマンドの一部を誤って使用すると、データの整合性の問題やデータ ロスを引き起こす可能性があります。コマンドまたはそれを実行した結果について理解できない場合は、 Dellサポート または地域のDellパートナー担当者にサポートを依頼してください。

前提 条件:
avmaint config --ava | grep <setting>
  • 手動メンテナンスは避けてください。可能な限り、メンテナンス スケジューラーがメンテナンス タスクを管理できるようにします。
手順:
  1. システムで作業する前に、次のコマンドを使用して、Avamar Serverの一般的なステータスを理解して、次の質問に回答する必要があります。
  • 最後に検証されたチェックポイントは何歳ですか?
cplist
  • すべてのストライプがオンラインですか? すべてのノードがオンラインですか?
status.dpn
  • すべてのサービスが稼働していますか?
dpnctl status
  1. 実行中のメンテナンスを確認し、必要に応じてキャンセルします。
    1. メンテナンス スケジューラーを使用してメンテナンス アクティビティーを一時停止し、停止後に再開されないようにします。
avmaint sched suspend cp --ava
avmaint sched suspend hfscheck --ava
不要なロールバックが発生する可能性があるため、ガベージ コレクション(GC)を中断しないでください
  1. 次のコマンドを実行し、実行中のメンテナンス アクティビティを確認します。
status.dpn
  • チェックポイントが実行中の場合は、完了させます。
  • HFScheck が実行されている場合、サーバーが管理モード (waitcgsan フェーズ) になっていない場合、または HFScheck がほぼ完了していれば、HFScheck を停止できます。
avmaint hfscheckstop --ava
  • GCが実行されている場合は、次のように強制終了できます。
avmaint gckill --ava
現在のパスが終了する必要があるため、完了するまでに時間がかかる場合があります。
  1. メンテナンスが実行されなくなったら、メンテナンス スケジューラーを停止する必要があります。
dpnctl stop maint
  1. バックアップ スケジューラーを停止し、バックアップまたはリストアの実行を停止して、新しい接続を一時停止します。
    1. MCSが新しいバックアップを開始できないようにします。
dpnctl stop sched
  1. 実行中のすべてのバックアップを一覧表示します。
avmaint sessions --ava | grep sessionid
レプリケーション以外のリストアが実行されている場合は、リストアの完了を許可するかどうかをユーザーと相談して判断してください。
  1. ユーザーから承認を受け取ったら、UIを使用してバックアップをクリーンに強制終了(部分バックアップが作成される)にするか、次を使用して不正に強制終了できます。
avmaint kill -waittime=0 <sessionid>
  1. 前のコマンドでリストされていない追加のバックアップを一覧表示します。
avmaint sessions --full
  1. 実行する操作によっては、バックアップ タイプの操作(avmaint getrefby)を実行できない場合があります。したがって、ディスパッチャーを一時停止して、手動バックアップを許可しないようにします。
avmaint suspend
  1. レプリケーション(レプリケーション ソースまたはターゲット)を停止します。
    1. レプリケーション ソース(リストア)の場合は、UIまたはEMを使用するか、プロセスを強制終了してレプリケーションを停止します。
    2. レプリケーション ターゲット(バックアップ)の場合、レプリケーションが実行されているかどうかを確認します。 
avmaint sessions | grep path
  1. パスで /REPLICATE ドメインを探します。ステップ4aの方法を使用して、ソース グリッドでレプリケーションを停止します。
  1. 次のコマンドを使用して、クランチングをオフにします。
avmaint config --ava asynccrunching=false
クランチングが停止するまでに最大15分かかる場合があります。データ ノードのGSANログで「クランチ」メッセージがないか確認してください。
  1. バランシングをオフにする
    1. バランシングが実行されているかどうかを確認します。
avmaint config --ava | grep balancemin
通常、バランシングは有効にしないでください(0以外の値)が、それでも確認することは重要です。
  1. バランシングを無効にするには、次の手順を実行します。
avmaint config --ava balancemin=0
バランシングが停止するまでに最大15分かかる場合があります。status.dpnをチェックして、移行中のストライプがあるかどうかを確認し、バランシングが完了したことを確認します。
  1. 容量を確認します。
    1. OS容量を確認します。 
avmaint nodelist --ava | grep fs-perc
  1. チェックポイントのサイズを確認します。
mapall copy ~/cps                # only if cps does not exist on the data nodes
mapall --noerror './cps'
  1. チェックポイント リストを確認して、保持する必要があるチェックポイント(すべてのノードで最後に検証されたチェックポイント)を決定します。
cplist
上記の結果に応じて、保持できるチェックポイントの数、重要なチェックポイント、作成できる新しいチェックポイントの数を決定します。
容量の詳細については、「Avamar: 容量管理の概念とトレーニング
  1. ノードの順序と、論理ノード番号と物理ノード番号の違いに注意してください。
nodenumbers
status.dpn
mapall --noerror 'tail -2 /data01/cur/gsan.log'
  1. ハードウェアを確認します
  • これで、すべての自動化タスクが停止されます。 
  • サーバーのアクティビティーがほとんどなく、手動のタスクやコマンドを安全に実行できる必要があります。 
データ ノード全体でGSANログを確認して、サーバーを確認します。ログに記録されているアクティビティがほとんどないか、またはまったく記録されていないことを確認します。
uptimeコマンドはmapallを使用して実行し、データ ノード全体の「負荷平均」が低い(0.01から0.05

の間)ことを確認することもできます。次に例を示します。
mapall --noerror 'uptime' 

(0.0) ssh  -x  admin@10.xx.xx.xxx 'uptime'  
  16:39:29 up 100 days,  6:39,  0 users,  load average: 0.01, 0.02, 0.01 
(0.1) ssh  -x  admin@10.xx.xx.xxx 'uptime'  
  16:39:29 up 100 days,  6:39,  0 users,  load average: 0.02, 0.01, 0.01 
(0.2) ssh  -x  admin@10.xx.xx.xxx 'uptime'  
  16:39:29 up 100 days,  6:39,  0 users,  load average: 0.02, 0.01, 0.01
上記の手順では、サーバーを非本番状態に設定します。すべての手動タスクが完了したら、必ず変更を元に戻します。

其他信息

 

受影响的产品

Avamar, Avamar Server
文章属性
文章编号: 000170876
文章类型: Solution
上次修改时间: 06 8月 2025
版本:  15
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。