PowerPath 6.0으로 업그레이드한 후 디스크가 오프라인으로 표시됨
摘要: PowerPath 6.0으로 업그레이드한 후 디스크가 오프라인으로 표시됩니다.
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
PowerPath 6.0으로 업그레이드한 후 일부 디스크가 오프라인으로 표시됩니다.
原因
디스크를 온라인 또는 오프라인으로 만드는 것은 PowerPath가 아닌 Windows 기능입니다.
解决方案
사용자는 오프라인 문제를 해결하기 위해 아래를 실행해야 합니다.
Windows Server 2008 이상 및 Windows Server 2008 R2의 경우 기본 SAN 정책은 OfflineShared입니다.
디스크를 온라인/오프라인으로 만드는 것은 Windows 기능이므로 위의 제한 사항은 혼란스럽습니다.
san policy=onlineall
Windows용 Dell PowerPath 및 PowerPath/VE 제품군 버전 6.0 릴리스 노트는 PowerPath의 제한 사항으로 디스크의 온라인 또는 오프라인 동작을 제공합니다.
Windows Server 2008 이상에서는 디스크가 호스트에 처음 추가될 때 오프라인으로 표시됩니다.
이러한 오프라인 디스크를 사용하려면 먼저 사용자가 수동으로 설정해야 합니다.
이 문제를 방지하려면 diskpart에서 san policy=onlineall 명령을 실행합니다.
이 명령은 새 SAN 드라이브를 온라인 상태로 유지하도록 시스템을 구성합니다.
이러한 오프라인 디스크를 사용하려면 먼저 사용자가 수동으로 설정해야 합니다.
이 문제를 방지하려면 diskpart에서 san policy=onlineall 명령을 실행합니다.
이 명령은 새 SAN 드라이브를 온라인 상태로 유지하도록 시스템을 구성합니다.
Windows Server 2008 이상 및 Windows Server 2008 R2의 경우 기본 SAN 정책은 OfflineShared입니다.
디스크를 온라인/오프라인으로 만드는 것은 Windows 기능이므로 위의 제한 사항은 혼란스럽습니다.
요약하자면, 호스트 측에서 물리적 디스크를 추가하고 스캔한 후 모의 디바이스가 오프라인으로 표시되거나 오프라인으로 전환되고 PowerPath가 이를 제어합니다(이미 존재하는 온라인 디스크가 온라인 상태로 제공됨).
其他信息
- SAN 정책 변경
DISKPART> san SAN Policy : Offline Shared Change it using.. DISKPART> san policy=OnlineAll DiskPart successfully changed the SAN policy for the current operating system. then list the disks using.. DISKPART> LIST DISK if any disk shows Offline, select that disk and clear the attributes. DISKPART> select disk Disk# Disk# is now the selected disk. DISKPART> ATTRIBUTES DISK CLEAR READONLY Disk attributes cleared successfully. DISKPART> attributes disk Current Read-only State : No Read-only : No Boot Disk : No Pagefile Disk : No Hibernation File Disk : No Crashdump Disk : No Clustered Disk : No DISKPART> ONLINE DISK DiskPart successfully onlined the selected disk.
- 디스크 관리를 통해 디스크 상태를 온라인으로 변경합니다.
POLICY=OnlineAll을 사용하여 이 문제를 해결할 수 있지만 디스크가 서버 간에 공유되는 경우 데이터 손상으로 이어질 수 있음을 분명히 해야 합니다. 사용자는 적절한 SAN 정책을 사용하여 데이터를 보호하는 것이 좋습니다.
文章属性
文章编号: 000171325
文章类型: Solution
上次修改时间: 11 3月 2024
版本: 3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。