RESTAPI-opkald tager for lang tid at returnere, hvilket forårsager VSS-timeoutfejl i Appsync

摘要: RESTAPI-opkald, der tager lang tid at returnere, hvilket medfører VSS-timeoutfejl i Appsync

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Kunden bruger AppSync, der anvender RESTAPI til at tage snapshot på Windows 2016-værter. Det bruger Microsoft VSS, som kræver svar inden for 10 sekunder, og det tager godt og vel denne tid RESTAPI at svare, selvom snapvx-sessionen gennemføres på mindre end ét sekund.

I AppSync-logfilerne ser vi anmodningen om snapshot, og kort tid efter ser vi snapvx oprette start i SYMAPI-logfilerne. Et snapshot er klar om mindre end et sekund. Men returneringen fra RESTAPI til AppSync sker ikke inden for de næste 30 sekunder, efter at snapshottet er færdigt. Vi kan se følgende i SMAS- og RESTAPI-logfiler (der kræves INFO-logføring på Unisphere):

INFO [em.bp.RESTAPIUSAGE] (default task-611) /private/91/replication/symmetrix/{symmetrixId}/snapshot/{snapshotName} AppSync/4.1.0.1_2492_R2/<IP_address>    POST    36829 ms    201    null    null    null

原因

I dette tilfælde kunne dette problem ses, når kunden tog snapshot af individuelle enheder i stedet for på Storage Group-niveau. De tog snapshot af over 50 enheder, der bidrog til den tid, det ville tage at returnere RESTAPI-forespørgslen tilbage til AppSync. 

For at løse dette problem har teknikere udviklet en arkitektonisk ændring til at justere RESTAPI-opkald, så de ville svare under VSS timeout på 10 sekunder

解决方案

Rettelse: Der findes et hotfix, der løser dette problem. Der kræves et hotfix til både Unisphere og AppSync for at løse dette problem. Kontakt support, og henvis til denne KB-artikel for at bede om følgende rettelser:

- Unisphere for PowerMax 9.2.0.9
- AppSync patch 4.1.0.1_2492_R3

Begge rettelser er påkrævet for at løse dette problem.

受影响的产品

Unisphere for PowerMax
文章属性
文章编号: 000182815
文章类型: Solution
上次修改时间: 06 11月 2025
版本:  6
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。