Диспетчер SRDF/TimeFinder. Ошибка при использовании команды STM IASPCTL REMOVEIOA образ не найден

摘要: После использования команды STM IASPCTL REMOVEIOA на первичном/исходном узле все команды STM на образе IASP завершаются сбоем. Это наблюдалось в сборках STM 9.1 и позже в IBMi 7.4. Он отлично работает на более ранних версиях IBMi. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Возникает проблема, при которой пользователи получают сообщение об ошибке IASPCTL (источник). Эта же команда работает и с IASPCTLC

Команды завершаются сбоем на узле SOURCE без видимых причин. 

Если команда IASPCTL STATUS выполняется до процесса переключения, она работает. Затем, после того как iASP будет VARY OFF и выполнена команда IASPCTL REMOVEIOA, та же команда IASPCTL STATUS внезапно завершится сбоем с сообщением «Image image-name not found»

В кластере на нашем тестовом S3TESTQ LPAR с именем iASP «TESTQ» отображается такое же поведение:    

Capture1.PNG

Выполнение команды STATUS завершается сбоем, но также наблюдается сбой команды SRDFDRCTL с той же ошибкой. Выполняется команда IASPCTLC с помощью команды CTLACTTGT для смены ролей, а затем выполнения команды status с целевого узла.

原因

Эта проблема возникает в IBMi V7R4 с STM 9.1 и более поздних версий. В 7.2 и 7.4 в некоторые API IBM были внесены изменения, которые, как предполагается, вызывают эту проблему. Эти API-интерфейсы используются в Solutions Enabler и STM. В настоящее время эта проблема изучается компаниями Dell и IBM. IBM внесла изменения в API управления дисками IBM, отвечающий за выполнение REMOVEIOA. Изменения были сделаны для того, чтобы предотвратить случайный перенос частичных флэш-копий в режим онлайн и доступ к ним после завершения флэш-памяти.

解决方案

Временное решение этой проблемы заключается в выдаче команд с резервного узла (узлов). 

После REMOVEIOA можно выполнять команды с узла аварийного восстановления.

Чтобы вернуть основной узел в правильное состояние, необходимо выполнить команду IASPCTLC ADDIOA с резервного узла и команду DISCOVER на основном узле.
文章属性
文章编号: 000183564
文章类型: Solution
上次修改时间: 04 3月 2021
版本:  1
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。