SRDF/TimeFinder Manager: Erro ao usar o comando STM IASPCTL Imagem REMOVEIOA não encontrada

摘要: Depois de usar o comando STM IASPCTL REMOVEIOA no nó principal/de origem, todos os comandos STM na imagem IASP falham. Isso foi observado nas compilações STM 9.1 e posteriores no IBMi 7.4. Ele funciona bem em versões inferiores do IBMi. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Ocorre um problema em que os usuários obtêm um erro com IASPCTL (origem). O mesmo comando funciona com IASPCTLC

. Os comandos estão falhando no nó SOURCE sem motivo aparente. 

Quando o comando IASPCTL STATUS é executado antes do processo de switch, ele funciona. Em seguida, depois que o iASP é VARIED DESLIGADO e o comando IASPCTL REMOVEIOA é executado, o mesmo comando IASPCTL STATUS falha repentinamente com 'Image image-name not found'

Em um cluster em nosso S3TESTQ LPAR de teste com nome iASP "TESTQ", está mostrando o mesmo comportamento:    

Capture1.PNG

O comando STATUS falha, mas o comando SRDFDRCTL também falhando com o mesmo erro. Usando o comando CTLACTTGT para fazer a troca de função e, em seguida, executar o comando status do nó de destino, o comando IASPCTLC funciona.

原因

Esse problema ocorre no IBMi V7R4 com STM 9.1 e posterior. Foram feitas alterações em algumas das APIs da IBM nas versões 7.2 e 7.4, que são suspeitas de causar esse problema. Essas APIs são usadas no Solutions Enabler e no STM. No momento, o problema está sendo investigado entre a Dell e a IBM. A IBM fez alterações na API de gerenciamento de disco IBM responsável por executar o REMOVEIOA. As alterações foram feitas para evitar que flashcopies parciais fossem acidentalmente colocadas on-line e acessadas após o término do flash.

解决方案

A solução temporária para esse problema é emitir os comandos dos nós de backup. 

Após REMOVEIOA, os comandos do nó DR podem ser emitidos.

Para trazer de volta o nó primário para o estado correto, o comando IASPCTLC ADDIOA deve ser emitido a partir do nó de backup e o comando DISCOVER deve ser executado no primário.
文章属性
文章编号: 000183564
文章类型: Solution
上次修改时间: 04 3月 2021
版本:  1
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。