IDPA: ACM-grensesnittet viser feilen "Backup Server viewuser user password is out of sync. Oppdater det nyeste passordet» på instrumentpanelet for sikkerhetskopieringsserveren

摘要: Denne artikkelen dekker problemet der brukerpassordet for Visningsprogram på Avamar/Backup Server er uendret, men ACM-brukergrensesnittet viser feilen «Brukerpassordet for sikkerhetskopieringsservervisning er usynkronisert). Oppdater det nyeste passordet på instrumentpanelet for sikkerhetskopieringsserveren. Dette problemet kan oppstå hvis et verktøy er i ferd med å oppgradere kode. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

ACM-grensesnittet viser feilen "Backup Server viewuser user password is out of sync. Oppdater det nyeste passordet på instrumentpanelet for sikkerhetskopieringsserveren.

Når brukeren klikker på popup-vinduet password out of sync og prøver å oppdatere passordet, viser brukergrensesnittet feilen «Avamar viewuser user test connection failed»:


viewuser1.png
Open SSH to ACM as 'root' user and run the following command to confirm if this issue is caused due to MCSDK compatibility where ACM is unable to login to Avamar or Backup Server Postgres Database using MCSDK:
 
grep -i "SQLException.*viewuser.*authentication.*not supported" -A2 /usr/local/dataprotection/var/configmgr/server_data/logs/server.log


Eksempel:
2021-03-30 10:45:25,304 INFO [https-jsse-nio-8543-exec-10]-restadapter.LoginService: Test connection failed for Avamar server viewuser
2021-03-30 10:49:08,451 ERROR [Thread-379779]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.
2021-03-30 10:57:57,402 ERROR [https-jsse-nio-8543-exec-10]-avadapter.AvamarUtil: SQLException while checking viewuser connection: org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.



Kommandoen ovenfor peker på et kompatibilitetsproblem mellom ACM og Avamar/Backup Server MCSDK fordi ACM ikke er i stand til å hente visningspassordstatus ved å logge på Postgres-databasen på Avamar-serveren. 

Åpne SSH til Avamar eller Backup Server, og kontroller om visningspassordet fungerer på manuelt påloggingsforsøk.
  • Kontroller at visningsbrukerens pålogging fungerer ved hjelp av følgende kommando:
    • psql -p 5555 mcdb -U viewuser -h 
Merk: Hvis pålogging fungerer med gjeldende visningspassord eller vanlig passord, har vi riktig passord. 

Når vi har identifisert riktig passord, klikker du på passordet for brukerpassordet som ikke er synkronisert, og prøver å oppdatere dette passordet. Hvis vi ser testtilkoblingsfeil, går du videre til løsningsdelen.

原因

Kompatibilitetsproblem mellom ACM og Avamar eller sikkerhetskopieringsserver. Dette problemet kan oppstå hvis Avamar har blitt oppgradert til høyere versjon, men ACM er ennå ikke oppgradert. For eksempel når det gjelder IDPA DP8X-modeller, er Avamar ikke en del av arbeidsflyten for IDPA-oppgradering og oppgraderes som en del av en egen arbeidsflyt. 

Anbefaling for IDPA DP8X-oppgraderinger:
  • Arbeidsflyten for IDPA-oppgradering fra ACM må startes først. 
  • Når arbeidsflyten for IDPA-oppgradering når ESXi-oppgraderingsfasen, kan Avamar-oppgradering deretter startes for å unngå slike kompatibilitetsproblemer. 
Merk: Hvis anbefalingene ovenfor ikke følges, kan det føre til at slike passord blir usynkronisert.

解决方案

1. Åpne SSH til Avamar Server/ Backup Server som "admin user and verify the following details:
mcserver.sh --version


2. Åpne SSH til ACM som rotbruker, og kontroller IDPA-versjonen:
rpm -qa | grep -i dataprotection



3. Kontroller at ACM-versjonen samsvarer med den respektive Avamar-versjonen i henhold til leverandøren av stabeltabellen nedenfor:
 
IDPA-versjon (ACM-versjon) Avamar- eller sikkerhetskopieringsserverversjon
2.2 7.5.1.101
2.3.x 18.2.0.134
2.4.x 18.2.0.134
2,5 19.1.0.38
2.6.x 19.3.0.149

Merk: Hvis ACM- og Avamar-versjonene som er angitt i trinn 1 og 2, ikke samsvarer med tabellen ovenfor, vil dette forklare kompatibilitetsproblemet. 

4. Oppgrader resten av IDPA- eller Avamar-versjonene slik at de samsvarer med IDPA Stack-versjonene. Hvis dette er et DP8X-verktøy midt i en oppgradering, forventes denne feilen og venter til oppgraderingsprosessen fullføres fullstendig.

受影响的产品

Integrated Data Protection Appliance Family

产品

PowerProtect DP8300, PowerProtect DP8800, PowerProtect Data Protection Software, PowerProtect Data Protection Hardware, PowerProtect DP8400, PowerProtect DP8900
文章属性
文章编号: 000185598
文章类型: Solution
上次修改时间: 01 9月 2023
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。