CloudLink:CloudLink 节点卡在紧急模式下

摘要: CloudLink 节点卡在紧急模式下。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

启动 CloudLink 节点后,将看到以下消息: 
Welcome to emergency mode! After logging in, type "journalctl -xb" to view
system logs, "systemctl reboot" to reboot, "systemctl default" or ^D to
try again to boot into default mode.
Press Enter for maintenance
(or press Control-D to continue):
启动 Cloudink 节点后显示的消息

 

原因

此问题是由于必须修复的文件系统问题造成的。

解决方案

要解决节点上的文件系统问题,请执行以下操作:
  1. 您可以按 Control-D 继续,但它仍处于紧急模式。
  2. 按 ENTER 键进行维护。
  3. 在根 ( / ) 文件系统上运行文件系统检查。
root@cloudlink:~#  lsblk    

  1. y 以修复找到的任何错误。
  2. 重新启动节点。

如果根文件系统是干净的,则可以使用上述相同过程在其他文件系统上运行 fsck。
运行命令 journalctl -xb 。这些日志可能指示是否有需要修复的损坏的文件系统。
您可以使用命令 lsblk blkid 来帮助将 uuid 链接到其文件系统。
以下是您可能会在 journalctl -xb:
/dev/sda6 中看到的错误的一些示例:已找到属于损坏的孤立链接列表的索引节点。
/dev/sda6:意外不一致:手动运行 fsck。
无法在 /dev/disk/by-uuid/fd782a8-a70d-045513691c7e 上启动文件系统检查
如果您无法使用 fsck 修复文件系统,或者如果您有一个经常卡在紧急模式下的 Cloudlink 节点,则应从群集中删除损坏的 Cloudlink 节点。

然后,从 OVA 部署新的 Cloudlink 节点并加入到现有群集。

如果您可以修复文件系统,则应从 Cloudlink UI 检查群集的运行状况。
这在 SYSTEM >群集中完成,并确保传入和传出同步状态正常。

受影响的产品

CloudLink

产品

CloudLink SecureVM
文章属性
文章编号: 000197726
文章类型: Solution
上次修改时间: 14 7月 2023
版本:  5
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