Det går inte att säkerhetskopiera Oracle RMAN-säkerhetskopieringsfiler i NetWorker-filsystemet, men alla andra filer säkerhetskopieras
摘要: Användaren varnas inte när en VSS-skrivare som inte stöds (t.ex. Oracle VSS-skrivaren) upptäcks. Oracle-filer hoppas över under en säkerhetskopiering av NetWorker-filsystemet utan varning. ...
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
Använda en Windows-server som har en Oracle-databas installerad på den där Oracle VSS Writer-standardtjänster är installerade och aktiverade.
Använda Oracle RMAN för att skapa lokal säkerhetskopiering till disk, så att de säkerhetskopierade filerna sparas i en lokal katalog. När säkerhetskopieringen av filsystemet utförs slutförs den utan problem. Men när loggarna kontrolleras är det tydligt att NetWorker inte har säkerhetskopierat Oracle-filerna.
Använda Oracle RMAN för att skapa lokal säkerhetskopiering till disk, så att de säkerhetskopierade filerna sparas i en lokal katalog. När säkerhetskopieringen av filsystemet utförs slutförs den utan problem. Men när loggarna kontrolleras är det tydligt att NetWorker inte har säkerhetskopierat Oracle-filerna.
原因
När en standardsäkerhetskopiering av NetWorker-filsystem utförs på den här datorn identifieras alla Oracle-säkerhetskopieringsfiler av Oracle VSS Writer och läggs till i en lista som sedan tillhandahålls NetWorker för säkerhetskopiering. NetWorker-klientprogramvaran har inte stöd för Oracle VSS Writer. Ett tillfälligt direktiv om att hoppa över alla filer i listan genereras automatiskt. Det innebär att alla Oracle-säkerhetskopieringsfiler hoppas över utan någon varning till NetWorker-användaren. Säkerhetskopieringen lyckas, men inga Oracle-säkerhetskopieringsfiler har säkerhetskopierats.
解决方案
Den aktuella lösningen på problemet är att utföra sparåtgärden med alternativet "VSS:*=off" eller ha Oracle VSS-skrivaren inaktiverad eller avinstallerad. Detta kan ställas in i klientegenskaperna via NetWorker Management Console (NMC):
Bild 1: Skärmbild av klientegenskaper för NetWorker Management Console
En officiell förbättringsbegäran (referens RFE # NW-I-1965) visas med Dell NetWorker Product Management-teamet för att begära att ett varningssystem implementeras i framtida NetWorker-versioner så att de överhoppade filerna enklare upptäcks av användaren. Din kontoansvarige på Dells webbplats eller säljare kan spåra och koppla alla RFE:er.
Bild 1: Skärmbild av klientegenskaper för NetWorker Management Console
En officiell förbättringsbegäran (referens RFE # NW-I-1965) visas med Dell NetWorker Product Management-teamet för att begära att ett varningssystem implementeras i framtida NetWorker-versioner så att de överhoppade filerna enklare upptäcks av användaren. Din kontoansvarige på Dells webbplats eller säljare kan spåra och koppla alla RFE:er.
文章属性
文章编号: 000200983
文章类型: Solution
上次修改时间: 02 6月 2023
版本: 3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。