La sauvegarde du système de fichiers NetWorker ne parvient pas à sauvegarder les fichiers de sauvegarde Oracle RMAN, mais sauvegarde tous les autres fichiers

摘要: Il n’y a aucun avertissement pour l’utilisateur lorsqu’un writer VSS non pris en charge (tel que Oracle VSS Writer) est détecté. Les fichiers Oracle sont ignorés lors d’une sauvegarde du système de fichiers NetWorker sans avertissement. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

À l’aide d’un serveur Windows sur lequel est installée une base de données Oracle sur laquelle les services Oracle VSS Writer par défaut sont installés et activés.

Utilisation d’Oracle RMAN pour créer une sauvegarde locale sur disque, en enregistrant les fichiers générés par la sauvegarde dans un répertoire local. Chaque fois que la sauvegarde du système de fichiers est effectuée, elle se termine avec succès. Toutefois, lorsque les logs sont vérifiés, il est évident que NetWorker n’a pas sauvegardé les fichiers Oracle.

原因

Lorsqu’une sauvegarde standard du système de fichiers NetWorker est effectuée sur cette machine, tous les fichiers de sauvegarde Oracle sont détectés par Oracle VSS Writer et sont ajoutés à une liste qui est ensuite fournie à NetWorker pour la sauvegarde. Le logiciel NetWorker Client ne prend pas en charge Oracle VSS Writer. Une directive temporaire permettant d’ignorer tous les fichiers de la liste fournie est générée automatiquement. Par conséquent, tous les fichiers de sauvegarde Oracle sont ignorés sans avertissement pour l’utilisateur NetWorker. La sauvegarde a réussi, mais aucun fichier de sauvegarde Oracle n’a été sauvegardé.

解决方案

La solution de contournement actuelle pour ce problème consiste à effectuer l’opération d’enregistrement avec l’option « VSS:*=off » ou à désactiver ou désinstaller Oracle VSS Writer. Cela peut être défini dans les propriétés du client via NetWorker Management Console (NMC):
 
Capture d’écran Propriétés du client NetWorker Management Console
Figure 1 : Capture d’écran Propriétés du client NetWorker Management Console 

Une demande d’amélioration officielle (référence RFE # NW-I-1965) est envoyée à l’équipe de gestion des produits Dell NetWorker pour demander la mise en œuvre d’un système d’avertissement dans les futures versions de NetWorker, afin que les fichiers ignorés soient plus facilement détectés par l’utilisateur. Votre responsable de compte ou ingénieur commercial sur site Dell peut suivre et lier toutes les demandes d’assistance.
文章属性
文章编号: 000200983
文章类型: Solution
上次修改时间: 02 6月 2023
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。