PowerStore: La adición del iniciador falla con el error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

摘要: La adición del iniciador falla con el error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Dispositivo que ejecuta PowerStore OE 2.2.1
Dos hosts (host1 y host2) se asignaron por error a iniciadores con el mismo WWPN
El WWPN duplicado se elimina del host1
La salida de la GUI y la PSTCLI no muestran el WWPN eliminado en uso por ningún host.
Intentar agregar el WWPN que se eliminó del host1 al host2 falla con el error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Nota: Ignore la referencia de IQN; el problema se aplica a cualquier tipo de iniciador.

Ejemplo de problema:
  1. Cree 2 hosts, host1 con WWPN A, B, host2 con WWPN C. 
  2. Agregue esos hosts a un grupo de hosts.
  3. Agregue el WWPN A al host2. Se realizó correctamente. Ahora cada host tiene 2 iniciadores. Esto es incorrecto. 2 hosts no pueden usar el mismo WWPN.
  4. Quite EL WWPN A del host1. WWPN A parece eliminarse de ambos hosts en la GUI, pero no se elimina de la base de datos subyacente para el host2.
  5.  Ahora intente agregar WWPN A al host2. Falla con el error "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

El iniciador que intentamos agregar no aparecerá en la lista del host en la GUI.

GUI

El iniciador que intentamos agregar tampoco se encontrará en ningún otro host mediante pstcli 
"host show -select name, os_type, host_initiators"
PSTCLI

原因

Hay un problema con PowerStore OE 2.1.1.1 que permite agregar un iniciador duplicado a un host existente.

解决方案

Solución alternativa:
si se encuentra este problema, comuníquese con el soporte técnico de Dell y mencione este artículo para obtener ayuda.

Solución:
este problema se corrigió en PowerStore OE 3.0.0.1 y versiones posteriores.

受影响的产品

PowerStore
文章属性
文章编号: 000205128
文章类型: Solution
上次修改时间: 27 7月 2023
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。