PowerStore: A adição do iniciador falha com o erro "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

摘要: A adição do iniciador falha com o erro "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Equipamento que executa o PowerStore OE 2.2.1
Dois hosts (host1 e host2) foram atribuídos por engano iniciadores com o mesmo WWPN
O WWPN duplicado é excluído do host1
A saída da GUI e do PSTCLI não mostra o WWPN excluído em uso por nenhum host.
A tentativa de adicionar o WWPN que foi excluído do host1 ao host2 falha com o erro "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

Nota: Ignore a referência IQN, o problema é aplicável a qualquer tipo de iniciador.

Exemplo de problema:
  1. Crie 2 hosts, host1 com WWPN A, B, host2 com WWPN C. 
  2. Adicione esses hosts a um grupo de hosts.
  3. Adicione o WWPN A ao host2. Foi bem-sucedido. Agora, cada host tem 2 iniciadores. Isso está errado. 2 hosts não podem usar o mesmo WWPN.
  4. Remova o WWPN A do host1. O WWPN A parece ser removido de ambos os hosts na GUI, mas não é removido do banco de dados subjacente para o host2.
  5.  Agora tente adicionar o WWPN A ao host2. Ele falha com o erro "Cannot add IQN since it already exists as part of the host (0xE0A01001000C)"

O iniciador que estamos tentando adicionar não será listado no host na GUI.

GUI

O iniciador que estamos tentando adicionar também não será encontrado em nenhum outro host usando o PSTCLI 
"host show -select name, os_type, host_initiators"
PSTCLI

原因

Há um problema com o PowerStore OE 2.1.1.1 que permite adicionar um iniciador duplicado a um host existente.

解决方案

Solução temporária:
se esse problema for encontrado, entre em contato com o suporte técnico da Dell e consulte este artigo para obter assistência.

Correção:
esse problema é corrigido no PowerStore OE 3.0.0.1 e versões posteriores.

受影响的产品

PowerStore
文章属性
文章编号: 000205128
文章类型: Solution
上次修改时间: 27 7月 2023
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。