安全連線閘道:由於帳戶遭鎖定,無法修改原則管理員設定

摘要: 本文說明在原則管理員上變更密碼後,無法修改使用者介面上的原則管理員設定的情況。此外,安全連線閘道密碼箱重設。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

安全連線閘道使用者介面在嘗試修改或停用原則管理員時,會提示未知錯誤,且無法儲存:
PM 上的未知錯誤
 
From /var/lib/docker/volumes/esrslog/_data/var/log/esrs/policymanager.log (Error code 423, text "User account is locked"):
ERROR com.dellemc.iot.platform.pmc.service.pm.PolicyManagerInteractionService [http-nio-7778-exec-9, 559af94c-d8ae-48ee-8c49-c7ad28c81564, ] Got exception from server error code is 423, and error text is User account is locked.
ERROR com.dellemc.iot.platform.pmc.controller.advise.PolicyManagerControllerAdvice [http-nio-7778-exec-9, 559af94c-d8ae-48ee-8c49-c7ad28c81564, ] Error for {}
com.dellemc.iot.platform.pmc.exception.PolicyManagerClientException: Something went wrong at Backend. Please try after sometime.


Policy Manager 使用者介面已鎖定:
使用者介面上的帳戶鎖定

原因

  • 原則管理員密碼會在未先停用 SCG-PM 連線的情況下進行變更。
  • 安全連線閘道加密箱會在升級或故障診斷期間重設

解决方案

1、使用 SSH 登入安全連線閘道,發出下列命令:
Pre 5.16: # docker exec -u postgres esrsde-app psql -U postgres -d vapp -c 'delete from policy_manager_config'

Post 5.16: # docker exec esrsde-app psql -U postgres -d vapp -c 'delete from policy_manager_config'

2、從安全連線閘道使用者介面確認原則管理員設定是否已清除,
3、等待原則管理員使用者介面鎖定時間到期,並確認原則管理員登入正常運作,
4、重新設定安全連線閘道上的 Policy Manager 設定。

其他信息

如果遇到下列錯誤,請使用 Post 5.16 命令。
# docker exec -u postgres esrsde-app psql -U postgres -d vapp -c 'select * from policy_manager_config'
psql: error: connection to server on socket "/var/run/postgresql/.s.PGSQL.5432" failed: FATAL:  Peer authentication failed for user "postgres"

受影响的产品

Secure Connect Gateway - Virtual Edition
文章属性
文章编号: 000205944
文章类型: Solution
上次修改时间: 17 7月 2024
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。