Cloudlink Amazon S3 备份存储“拒绝访问”状态代码 403
摘要: 解决 Amazon S3 备份存储配置上的错误“Access Denied”状态代码 403。
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
测试对 Amazon S3 备份存储的访问时出现“Access Denied”:
Error like:
com.amazonaws.services.s3.model.AmazonS3Exception:访问被拒(服务:Amazon S3 状态代码:403 错误代码:AccessDenied 请求 ID:WX2272G8B4XMDJKZ S3 扩展请求 ID:[...]
Error like:
com.amazonaws.services.s3.model.AmazonS3Exception:访问被拒(服务:Amazon S3 状态代码:403 错误代码:AccessDenied 请求 ID:WX2272G8B4XMDJKZ S3 扩展请求 ID:[...]
原因
为 Amazon S3 上的存储桶设置的存储桶访问策略不正确。
解决方案
应用正确的存储区访问策略。下面是有效的存储区访问策略示例。
{
“版本”:"2012-10-17",
“声明”:[
{
“Sid”:“可视化编辑器0”,
“Effect”:“允许”,
“action”:[
ʺs3:GetObjectVersionTagging“,
ʺs3:ReplicateObject“,
“s3:GetObjectAcl”,
ʺs3:GetIntelligentTieringConfiguration“,
“s3:PutLifecycleConfiguration”,
“s3:GetObjectVersionAcl”,
“s3:PutObjectTagging”,
ʺs3:DeleteObject“,
“s3:DeleteObjectTagging”,
“s3:GetBucketPolicyStatus”,
“s3:GetObjectRetention”,
ʺs3:DeleteObjectVersionTagging“,
ʺs3:GetBucketNotification“,
ʺs3:GetReplicationConfiguration“,
“s3:PutObject”,
ʺs3:GetObject“,
“s3:PutBucketNotification”,
“s3:PutBucketLogging”,
ʺs3:GetAnalyticsConfiguration“,
“s3:GetObjectVersionForReplication”,
“s3:GetLifecycleConfiguration”,
“s3:GetInventoryConfiguration”,
“s3:GetBucketTagging”,
ʺs3:DeleteObjectVersion“,
ʺs3:GetBucketLogging“,
ʺs3:ListBucketVersions“,
ʺs3:ReplicateTags“,
ʺs3:RestoreObject“,
“s3:ListBucket”,
“s3:GetAccelerateConfiguration”,
ʺs3:GetBucketPolicy“,
ʺs3:PutEncryptionConfiguration“,
ʺs3:GetEncryptionConfiguration“,
ʺs3:AbortMultipartUpload“,
“s3:PutBucketTagging”,
ʺs3:GetObjectTagging“,
“s3:GetMetricsConfiguration”,
ʺs3:PutBucketVersioning“,
“s3:GetBucketPublicAccessBlock”,
ʺs3:ListBucketMultipartUploads“,
“s3:PutObjectVersionTagging”,
ʺs3:GetBucketVersioning“,
ʺs3:GetBucketAcl“,
“s3:PutInventoryConfiguration”,
“s3:PutObjectRetention”,
ʺs3:GetBucketCORS“,
ʺs3:GetBucketLocation“,
ʺs3:ReplicateDelete“,
ʺs3:GetObjectVersion”
],
“Resource”:[
ʺarn:aws:s3:::BUCKET“,
ʺarn:aws:s3:::BUCKET/*”
]
}
]
}受影响的产品
CloudLink SecureVM, CloudLink文章属性
文章编号: 000210609
文章类型: Solution
上次修改时间: 26 6月 2023
版本: 5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。