PowerStore. Веб-интерфейс (UI) недоступен после NDU до версии 3.0 и выше, перезагрузки узла или цикла включения/выключения устройства

摘要: Не удается получить доступ к веб-интерфейсу пользователя или выполнить команды интерфейса командной строки PowerStore в системе после NDU до версии 3.0 и выше, перезагрузки узла или цикла включения/выключения устройства. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Пользовательский интерфейс или интерфейс командной строки PowerStore Manager (RestAPI и PSTCLI) недоступны, и могут возникнуть следующие ошибки:
  • Пользовательский интерфейс PowerStore Manager недоступен (пользователи не могут войти в систему) после NDU, перезагрузки узла или цикла включения/выключения устройства:
  • Попытка входа в систему завершается сбоем с ошибкой: «Service unavailable. Please retry in a few minutes. (0xE04040010004)» или «503 Service Unavailable»
  • При переходе через мастер начальной настройки (ICW) с помощью сервисного порта может появиться сообщение «Loading...». На шаге Сведения о кластере, который продолжается некоторое время. В конечном итоге в пользовательском интерфейсе может появиться сообщение «The required appliance was not found or Request timed out».

В результате этой проблемы:
  • Для ненастроенных устройств
    • Невозможно получить доступ к странице входа в PowerStore Manager или войти в REST API.
    • Connection Utility не может отображать настроенные и ненастроенных устройства в такой среде из-за отсутствия IP-адреса обнаружения на устройствах.
  • Для настроенных устройств
    • Невозможно получить доступ к странице входа в PowerStore Manager или войти в REST API.
    • Добавление операции «Appliance» невозможно.

Доступ к системе с помощью ssh, если ssh не включен, используйте сервисные порты, как описано в PowerStore: Доступ по протоколам SSH и PowerStore Manager с помощью сервисных портов локальной сети.

Не удается выполнить команды pstcli.
[SVC:service@XXXXXXX-B user]$ pstcli -d  -u admin -session
Password (for host localhost):
The system was unable establish a secure connection to the storage server.
No IPv4 169.254/16 IP bonded on disc0:
 
[SVC:service@XXXXXXX-A user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether aa:aa:aa:aa:aa:aa brd ff:ff:ff:ff:ff:ff
    inet6 fe80::18df:bcff:fe34:2b4a/64 scope link
       valid_lft forever preferred_lft forever
 
[SVC:service@XXXXXXX-B user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether bb:bb:bb:bb:bb:bb brd ff:ff:ff:ff:ff:ff
    inet6 fe80::18df:bcff:fe34:2b4a/64 scope link
       valid_lft forever preferred_lft forever

 

 

原因

Эта проблема затрагивает только PowerStoreOS 3.0 и более поздних версий.
  • Во время загрузки узла служба avahi-autoipd случайным образом выбирает IP-адрес в диапазоне 169.254.0.0/16. Проверьте, использует ли другое устройство этот IP-адрес с помощью команды arping, а затем привязывает его к интерфейсу disc0.
  • IP-адрес интерфейса disc0 требуется для загрузки стека HTTP пути управления.
  • Из-за неожиданного ответа ARP от сетевого устройства в сетевой среде управления сервису avahi-autoipd не удается получить IP-адрес, что препятствует загрузке стека HTTP пути управления и приводит к потере доступа к WebUI и PSTCLI.

解决方案

Временное решение.
  • Определите устройство, которое отправляет непредвиденные ответы ARP в PowerStore.
  • Проблему можно устранить, останавливая коммутатор или устройство, действующее в качестве ARP прокси в сети управления. Для этого выполните одно из следующих действий:
    • Обновите микропрограмму коммутатора до версии, которая содержит исправление проблемы (относящаяся к коммутаторам Cisco, как описано в https://quickview.cloudapps.cisco.com/quickview/bug/CSCul01316)
    • Если параметр «proxy ARP» включен на коммутаторе для ДИАПАЗОНА IP-адресов Zeroconf/Avahi 169.254.0.0/16, рекомендуется отключить или перенастроить этот диапазон, так как он не должен использоваться для ARP прокси.
      • Обратитесь к сетевому администратору заказчика, чтобы убедиться, что отключение этого параметра не должно влиять на другие сетевые службы.
      • Проконсультируйтесь с администратором сети заказчика, чтобы лучше всего выполнить это изменение.
    • Изолировать сеть управления PowerStore в другой сети доступа или встроенной VLAN на коммутаторе.
  • После того как все вышеперечисленное будет выполнено, убедитесь, что у disc0 есть адрес IPv4 в диапазоне 169.254.0.0/16.
[SVC:service@XXXXXXX-A user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether ea:44:78:0a:05:c0 brd ff:ff:ff:ff:ff:ff
    inet 169.254.60.18/16 brd 169.254.255.255 scope link disc0:mc
       valid_lft forever preferred_lft forever


[SVC:service@XXXXXXX-B user]$ ip a show | grep disc0 -A 3
11: disc0@eno1:  mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 1a:df:bc:34:2b:4a brd ff:ff:ff:ff:ff:ff
    inet 169.254.64.234/16 brd 169.254.255.255 scope link disc0:mc
       valid_lft forever preferred_lft forever

 

 
     
    • Перезапустите controlpath 
    [SVC:service@XXXXXXX-B user]$ svc_container_mgmt restart CP
    Waiting for container restart
    Container controlpath restart returned: 0
    Container controlpath is back up
    Waiting for stack to load
    Waiting for stack to load
    Waiting for stack to load
    Waiting for stack to load
    [SVC:service@XXXXXXX-B user]$
    

    Если не удается определить сетевое устройство, отправляющее непредвиденные ответы ARP, или для устранения этой проблемы требуется помощь, обратитесь в службу технической поддержки или к уполномоченному представителю службы поддержки и укажите идентификатор этой статьи базы знаний Dell.

    Исправить:
    Эта проблема устранена в PowerStoreOS версии 3.6.0.0
    (см. MDT-498676 в примечаниях к выпуску для этой версии операционной системы).

    受影响的产品

    PowerStore, PowerStore 1000X, PowerStore 1000T, PowerStore 1200T, PowerStore 3000X, PowerStore 3000T, PowerStore 3200T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T

    产品

    PowerStore 5200T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T, PowerStore 9200T
    文章属性
    文章编号: 000211171
    文章类型: Solution
    上次修改时间: 23 10月 2023
    版本:  7
    从其他戴尔用户那里查找问题的答案
    支持服务
    检查您的设备是否在支持服务涵盖的范围内。