PowerPath для AIX: Надбудова PowerPath не налаштовує один шлях до пристрою, що призводить до дублювання PVID

摘要: У PowerPath можуть бути різні причини, щоб не вибрати шлях, і найпоширенішою причиною є невідповідність "reserve_policy" між hdisk і псевдопристроєм ... але в такому випадку псевдопристрій залишається «визначеним», оскільки PowerPath не знає, який reserve_policy потрібно застосувати до псевдопристрою. Тут доступні як hdiskpower, так і hdisk, що залишився, що призводить до дублювання проблеми PVID (той самий PVID на псевдопристрої, що й на залишковому hdisk). ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

DellEMC SW: PowerPath для AIX (будь-який випуск)Хоча

є 2 шляхи до пристроїв, налаштованих ОС, у PowerPath відсутній один із шляхів. В результаті PVID залишається на не налаштованому hdisk і на псевдопристрої.

e.g,
# powermt display dev=1
Pseudo name=hdiskpower1
Symmetrix ID=00029780XXXX
Logical device ID=00157
Device WWN=6000097000029780XXXX533030313537
state=alive; policy=SymmOpt; queued-IOs=0
==============================================================================
--------------- Host ---------------   - Stor -  -- I/O Path --   -- Stats ---
###  HW Path               I/O Paths    Interf.  Mode     State   Q-IOs Errors
==============================================================================
   5 fscsi6                 hdisk233   FA  2d:08 active   alive      0      0

# lspv
...
hdisk1          00c94fa75919388d                    myvg1 
...
hdiskpower1     00c94fa75919388d                    myvg1

 

 

原因

Процес (який неможливо ідентифікувати) утримує hdisk, не дозволяючи програмі PowerPath настроїти пристрій.

解决方案

Примусово керуйте залишком hdisk за допомогою PowerPath за допомогою "powermt manage dev=hdiskXX". "Powermt manage" поверне "Попередження: управління шляхом hdiskXX буде налаштовано після перезавантаження", доводячи, що диск зайнятий і це причина проблеми. Після перезавантаження диск дійсно буде під контролем PowerPath..

受影响的产品

PowerPath for AIX
文章属性
文章编号: 000215028
文章类型: Solution
上次修改时间: 03 7月 2024
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。