Yeni dağıtılan SRM, daha önce keşfedilen XtrmIO'yi bulamıyor

摘要: Yeni dağıtılan SRM, daha önce keşfedilen XtrmIO'yi bulamıyor

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Sorun aşağıda gösterilmiştir:

400badrequest.PNG

原因

Keşif komut dosyası, "&" alt dizeyi model özelliğinde mevcut olmadığında bile "&" ile değiştirmeye çalışıyor. 

line-24.PNG (satır 24.PNG)

解决方案

Geçici çözüm:
Alt dizeyi "&" ile değiştirin. Bu şekilde, alt dize yalnızca "&"
varsa değiştirilirYordam:
1. Söz konusu 2' de Dell EMC XtremiO için SolutionPack'i çalıştıran SRM toplayıcı VM'de oturum

açın. Şu dizine gidin: /opt/APG/Tools/Script-Engine/Default/data/emc-xtremio-collect-emc-xtremio


3. emc-xtremio-collect.sc1
cp emc-xtremio-collect.sc1 emc-xtremio-collect.sc1-backup4'in bir kopyasını

yedekleme. Şu dosyayı düzenle: emc-xtremio-collect.sc1 dosyasını takip edin:
Satırı değiştir:24
print ${model} | replace "<size-and-capacity json-type=\"string\">" "" | "</size-and-capacity>" yerine "" | "&" "&" |set modelver'i

şu yeni satırla değiştirin:
print ${model} | try replace "<size-and-capacity json-type=\"string\">" "" | "</size-and-capacity" yerine takmayı deneyin> "" | "&" "&" |set modelver

contents of a correctly modified script emc-xtremio-collect.sc1 like this: 

# Telif Hakkı (c) 2023, EMC Corporation.
# Tüm Hakları Saklıdır.
#
# Bu yazılım, EMC Corporation
#'ın fikri mülkiyetini içerir veya üçüncü taraflardan EMC Corporation'a lisanslendirilmiştir.
# Bu yazılımın ve

burada# bulunan fikri mülkiyetin kullanımı, EMC tarafından veya adına sağlanan Lisans Numarası Sözleşmesinin hüküm ve koşulları ile açıkça sınırlıdır.
#**********************************************************************************************
# Bu dosya, SolutionPack kodundan otomatik olarak oluşturuldu ve manuel olarak düzenlenemez. *
# Bu dosyada yapılan manuel değişiklikler kaybolabilir.                                    *
# Bu dosyayı yalnızca EMC'nin resmi önerileriyle düzenleyebilirsiniz.                                     *
#*İçoİçço.host
} 443
ssl-connect -t 30 ${emcxtremio. host} 443
step testrestfulapiauth ${emcxtremio.host}
set tempb64 "${emcxtremio.username}:${emcxtremio.password?password}"
http-get -k -t 30 -H "Authorization: Temel ${tempb64?base64}" -H "Content-Type: application/json" https://${emcxtremio.host}:443/api/json/types/clusters | json2xml | set xtremioapianswer
print ${xtremioapianswer} | xpath "/object/clusters/object/name/text()" | set xtremioapianswercluster
print ${xtremioapianswer} | xpath "(/object/clusters/object/href/text())[1]" | set xtremioclusterapi
println "Found cluster: ${xtremioapianswercluster}"
http-get -k -t 30 -H "Yetkilendirme: Temel ${tempb64?base64}" -H "Content-Type: application/json" ${xtremioclusterapi}| json2xml | set xtremioapianswer
print ${xtremioapianswer} | xpath "/object/content/sys-sw-version/text()" | set
version print ${xtremioapianswer} | xpath "/object/content/size-and-capacity" | set model
print ${model} | "<size-and-capacity json-type=\"string\">" "" | "</size-and-capacity" yerine takmayı deneyin> "" | "&" "&" |set modelver
println "Firmware Version: ${version}"
println "Model: ${modelver}"


5. XtremIO keşfini tekrar deneyin ve bu kez başarılı olur

文章属性
文章编号: 000217570
文章类型: Solution
上次修改时间: 13 11月 2023
版本:  2
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。