PowerProtect:Microsoft Application Agent for SQL 或 File Systems Agent 未正确注册

摘要: 由于 PowerProtect Data Manager 文件系统或 SQL Agent 注册不完整,主机未在 PowerProtect Data Manager 用户界面的“Asset Sources”页面下列出。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

安装 PowerProtect Data Manager Agent for Microsoft SQL Server 或 File Systems 后,PowerProtect Data Manager 用户界面 (UI) 的“Asset Sources”页面下缺少主机名。

 

在 PowerProtect Data Manager UI 的“应用程序代理”部分下,尽管注册状态设置为“Registered”,但“Agent Type”列下没有可用的信息。

 

以下是当主机出现问题时 PowerProtect Data Manager UI 的“应用程序代理”页面的示例:
PPDM 应用程序代理页面的示例
图 1:PowerProtect Data Manager 应用程序代理页面的示例

 

原因

在代理注册时发生的通信可能会因环境因素而遇到问题。受影响的版本中不存在超时和重试逻辑。

 

解决方案

使用以下步骤解决此问题:

  1. 确保在 PowerProtect Data Manager UI 中未运行任何发现作业。
  2. 暂停或禁用所有保护策略。
  3. 使用 SSH 会话登录到 PowerProtect Data Manager 服务器。
  4. 使用 命令以管理员用户身份登录时启动重新启动:
adm restart​

 

  1. 使用下面的命令,在 Microsoft Windows 主机上重新启动 PowerProtect Agent 服务,其中应用程序代理或文件系统代理有问题
C:\Program Files\DPSAPPS\AgentService\register.bat --stop

C:\Program Files\DPSAPPS\AgentService\register.bat --start

 

19.14 之后的 PowerProtect Data Manager 版本具有超时和重试逻辑,以便在出现故障时重试。

 

受影响的产品

PowerProtect Data Manager, PowerProtect Data Manager Essentials
文章属性
文章编号: 000218858
文章类型: Solution
上次修改时间: 02 9月 2025
版本:  4
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。