NetWorker:Oracle 备份失败,并显示错误“ORA 03113 end of file on communication channel”

摘要: Oracle 备份失败,并显示错误“ORA-03113: end-of-file on communication channel.”(ORA-03113:通信通道上的文件结尾)。

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

错误消息如下所示:

RMAN> run {
2> allocate channel c1 type 'sbt_tape' format '%d_%U';
3> }

using target database control file instead of recovery catalog
PSDRPC returns significant error 3113.
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of allocate command on c1 channel at 10/27/2023 13:07:49
ORA-03113: end-of-file on communication channel

sbttest was also failed:
[GW-DB:oracle:SJGW80:/]$sbttest /etc/hosts -no_proxy_backup -no_proxy_restore
The sbt function pointers are loaded from libobk.so library.
(pid 3839660): Failed to resolve hostname client1 to an internet address. Please verify a mapping for client1 exists in the /etc/hosts file or DNS.
-- sbtinit succeeded
(pid 3839661): Failed to resolve hostname client1 to an internet address. Please verify a mapping for client1 exists in the /etc/hosts file or DNS.
-- sbtinit (2nd time) succeeded
sbtinit: Media manager supports SBT API version 2.0
sbtinit: vendor description string=NMDA Oracle v19.4.0.6
sbtinit: allocated sbt context area of 2280 bytes
sbtinit: Media manager is version 19.4.0.0
sbtinit: proxy copy is supported
sbtinit: maximum concurrent proxy copy files is 0
(pid 3839659): Failed to resolve hostname client1 to an internet address. Please verify a mapping for client1 exists in the /etc/hosts file or DNS.

原因

这是因为用户 Oracle 无法访问 /etc/hosts 文件中定义。NMDA Oracle 备份使用用户 Oracle 而不是 root 用户启动。
[client1:root:/]# ls -arlt /etc/hosts
-rw------- l root root 233 10 20 11:27 /etc/hosts

[client1:oracle:/]$cat /etc/hosts
cat: /etc/hosts: Permmission denied

解决方案

授予读取权限 /etc/hosts 给用户 Oracle。
文章属性
文章编号: 000219976
文章类型: Solution
上次修改时间: 08 10月 2025
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。