S3-säilöobjektien luettelointisilmukat loputtomasti ohjelmointirajapinnan, ListObjectsin tai ListObjectsV2:n avulla
摘要: S3-sovellus tai s3cmd käyttää S3-ohjelmointirajapintaa listobject tai listobjectv2 kyselyyn objekteja s3-säilöstä, joissakin kulmatapauksissa Powerscale OneFS s3 palauttaa väärän tuloksen, jos dirCache on olemassa, mutta se ei täytä pyyntöä, S3-sovellus jumittuu, koska luettelo-objektit osuvat äärettömään silmukkaan. ...
本文适用于
本文不适用于
本文并非针对某种特定的产品。
本文并非包含所有产品版本。
症状
S3-sovellus vain jumittuu, koska luettelointia ei voida suorittaa loppuun.
S3cmd ls bucket saa toistuvasti samat objektit palautettua sivutettuun luetteloon.
S3cmd ls bucket saa toistuvasti samat objektit palautettua sivutettuun luetteloon.
原因
Tämä saattaa osua s3-välimuistivirheeseen# PSCALE-217613.
Jos asiakas pyytää ListObjects-kohteita, joiden enimmäismerkintä on = 1000, sisäisesti saamme 10 000 merkintää (jos hakemisto on hyvin laaja) ja palautamme niistä 1000 asiakkaalle, sitten käytä loput 9000 uudelleen tulevaa pyyntöä varten. Seuraavassa pyynnössä, jos välimuisti on ja hakemistossa on edelleen tiedostoja, joita ei ole vielä palautettu asiakkaalle, ja nykyisessä välimuistissa ei ole tarpeeksi merkintää pyynnön täyttämiseksi, osumme virheeseen ja palautamme väärän tuloksen.
解决方案
Suunnittelu työskentelee pysyvän korjauksen parissa, ja RUP-korjaustiedosto julkaistaan, kun se on valmis.
Nykyinen kiertotapa on määrittää s3 ls DIR_CACHE_TTL arvoon 0 väliaikaisesti:
Nykyinen kiertotapa on määrittää s3 ls DIR_CACHE_TTL arvoon 0 väliaikaisesti:
# isi_for_array -X "/usr/likewise/bin/lwsm inject s3 s3_ls_set_dir_cache_ttl on 0"
Jos s3-prosessi käynnistyy uudelleen tai solmu käynnistyy uudelleen, käytä kiertotapaa uudelleen solmussa, koska se on palautettu oletusarvoon 1 tunti, kun s3 käynnistettiin uudelleen.
Voit poistaa manuaalisen käytöstä DIR_CACHE_TTL:
#isi_for_array -X "/usr/likewise/bin/lwsm inject s3 s3_ls_set_dir_cache_ttl off"
受影响的产品
Isilon, PowerScale文章属性
文章编号: 000223936
文章类型: Solution
上次修改时间: 11 6月 2024
版本: 3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。