PowerFlex: Zálohování MSSQL 2019 selže a hlásí poškození nebo nekonzistenci dat

摘要: Při použití systému Windows 2019 SDC a spuštění zálohy Microsoft SQL 2019 zálohování selže a hlásí poškození nebo nekonzistenci dat (DI).

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

  • Windows 2019 s nainstalovaným SDC (Poznámka: Nejsou dotčena disková zařízení RDM/VMDK).
  • Je povolena funkce kontrolního součtu přeletu.
  • Zálohování Microsoft SQL 2019 selže s chybou:
    The log scan number (0:-1218248704:37) passed to log scan in database 'TEST_VOL' is not valid. This error may indicate data corruption or that the log file (.ldf) does not match the data file (.mdf). If this error occurred during replication, re-create the publication. Otherwise, restore from backup if the problem results in a failure during startup."
  • Trasy PowerFlex (MDM, SDS a SDC) nic nenasvědčují problému.

 

Poznámka: Problém byl zjištěn během selhání zálohování systému Microsoft SQL 2019, ale může mít vliv na jiné aplikace systému Windows.

 

Důsledky

Selhání
zálohování Microsoft SQL 2019 Nemá to žádný skutečný dopad na data ani žádné skutečné poškození dat nebo DI.

 

原因

Problém se softwarovým kódem v komponentě SDC, konkrétně s funkcí kontrolního součtu za provozu

Když je povolen průběžný kontrolní součet, Windows SDC změní stav FPU během výpočtů kontrolního součtu a neobnoví jej, což způsobí, že ostatní uživatelé instrukcí FPU, v tomto případě aplikace MSSQL, obdrží neočekávané výsledky.

 

解决方案

Jako alternativní řešení by měl být zakázán kontrolní součet za letu.

Pokud zástupné řešení není proveditelné, upgradujte na pevnou verzi, která je uvedená níže v části Verze s pevnou opravou. Oprava zahrnuje tok výpočtu kontrolního součtu, který uloží stav FPU před výpočtem kontrolního součtu a obnoví jej po dokončení výpočtu.

 

Dotčená verze

PowerFlex 3.x
PowerFlex 4.x

 

Opraveno ve verzi

PowerFlex 3.6.5
PowerFlex 4.5.3

 

受影响的产品

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
文章属性
文章编号: 000224854
文章类型: Solution
上次修改时间: 21 8月 2025
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。