PowerFlex: MSSQL 2019-Backup schlägt fehl und meldet Datenbeschädigung oder Inkonsistenz

摘要: Wenn Sie Windows 2019 SDC verwenden und ein Microsoft SQL 2019-Backup ausführen, schlägt das Backup fehl und meldet, dass Datenbeschädigung oder -inkonsistenz (DI) vorliegt.

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

  • Windows 2019 mit installiertem SDC (Hinweis: RDM/VMDK-Festplattengeräte sind nicht betroffen).
  • Die PowerFlex-In-Flight-Prüfsummenfunktion ist aktiviert.
  • Microsoft SQL 2019-Backup schlägt mit folgendem Fehler fehl:
    The log scan number (0:-1218248704:37) passed to log scan in database 'TEST_VOL' is not valid. This error may indicate data corruption or that the log file (.ldf) does not match the data file (.mdf). If this error occurred during replication, re-create the publication. Otherwise, restore from backup if the problem results in a failure during startup."
  • PowerFlex-Ablaufverfolgungen (MDM, SDS und SDC) Es gibt keine Hinweise auf ein Problem.

 

Hinweis: Das Problem wurde während des Backupfehlers von Microsoft SQL 2019 festgestellt, kann aber andere Windows-Anwendungen betreffen.

 

Auswirkungen

Microsoft SQL 2019-Backupfehler
Es gibt keine wirklichen Auswirkungen auf Daten oder echte Datenbeschädigung oder DI.

 

原因

Ein Softwarecodeproblem in der SDC-Komponente, insbesondere bei der In-Flight-Prüfsummenfunktion

Wenn die In-Flight-Prüfsumme aktiviert ist, ändert der Windows-SDC den FPU-Status während der Prüfsummenberechnungen und stellt ihn nicht wieder her, was dazu führt, dass andere Nutzer von FPU-Anweisungen, in diesem Fall die MSSQL-Anwendung, unerwartete Ergebnisse erhalten.

 

解决方案

Um dieses Problem zu umgehen, sollte die In-Flight-Prüfsumme deaktiviert werden.

Wenn der Workaround nicht möglich ist, führen Sie ein Upgrade auf die korrigierte Version durch, die im Abschnitt "Korrigierte in-Version" unten aufgeführt ist. Die Korrektur umfasst einen Prüfsummenberechnungsablauf, der den FPU-Status vor der Berechnung der Prüfsumme speichert und nach Abschluss der Berechnung wiederherstellt.

 

Betroffene Version

PowerFlex 3.x
PowerFlex 4.x

 

Behoben in Version

PowerFlex 3.6.5
, PowerFlex 4.5.3

 

受影响的产品

PowerFlex rack, PowerFlex Appliance, PowerFlex custom node, PowerFlex Software
文章属性
文章编号: 000224854
文章类型: Solution
上次修改时间: 21 8月 2025
版本:  5
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。