PowerStore: Ein Upgrade von PowerStoreOS 3.0/3.2 auf 4.0.0.x schlägt möglicherweise fehl und führt ein Rollback durch, wenn während des Prozesses neue SCSI-Reservierungen vorgenommen werden.

摘要: Die Durchführung eines Upgrades von PowerStoreOS 3.0.x oder 3.2.x direkt auf 4.0.0.x kann fehlschlagen und ein Rollback durchführen, wenn während des Upgradefortschritts neue SCSI-Reservierungsanforderungen vorhanden sind. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Die folgenden PowerStoreOS-Softwareversionen können von diesem Problem betroffen sein:
  • PowerStoreOS 3.0.x
  • PowerStoreOS 3.2.x

Durch die folgenden Änderungen an einer PowerStore-Umgebung kann dieses Problem auftreten:
  • Direktes Softwareupgrade von PowerStoreOS 3.0.x auf PowerStoreOS 4.0.0.x
  • Direktes Softwareupgrade von PowerStoreOS 3.2.x auf PowerStoreOS 4.0.0.x

Der folgende Hostmechanismus kann dazu beitragen, dieses Problem zu beheben:
  • Verwendung von SCSI-Reservierungen zur Steuerung des Zugriffs auf Volumes.
  • SCSI-Reservierungen werden in geclusterten Hostumgebungen, Hosts, die für hohe Verfügbarkeit konfiguriert sind, in virtualisierten Umgebungen und bei Verwendung von backup-/wiederherstellungsbasierten Anwendungen angezeigt.

原因

SCSI-Reservierungsanfragen, die während eines Softwareupgrades an eine PowerStore-Appliance gesendet werden, werden möglicherweise nicht ordnungsgemäß verarbeitet.

In seltenen Fällen können interne Services vorübergehend für einen kurzen Zeitraum beeinträchtigt werden.

解决方案

Problemumgehung

Wenn SCSI-Reservierungen verwendet werden, stehen die folgenden Optionen zur Verfügung:
  • Führen Sie ein Upgrade auf die neueste Version von PowerStoreOS 3.6.1.x durch und behalten Sie diese Softwareversion bei, bis eine Korrektur in einer zukünftigen PowerStoreOS-Version bereitgestellt wird.
  • Wenn PowerStoreOS 4.0.0.x-Funktionen erforderlich sind, führen Sie ein vorläufiges Upgrade auf die neueste Version von PowerStoreOS 3.6.1.x durch, bevor Sie ein Upgrade auf die neueste Version von PowerStoreOS 4.0.0.x durchführen.
  • Wenden Sie sich an den technischen Support von Dell, um vor einem Upgrade feststellen zu können, ob SCSI-Reservierungen auf einer PowerStore-Appliance aktiv sind. Verweisen Sie auf diesen Wissensdatenbank-Artikel im Service-Request für eine beschleunigte Abwicklung.
Informationen zu den neuesten Softwareangeboten für PowerStoreOS 3.6.1.x und PowerStoreOS 4.0.0.x finden Sie in der PowerStoreOS-Matrix.

受影响的产品

PowerStore, PowerStore 1000T, PowerStore 1200T, PowerStore 3000T, PowerStore 3200T, PowerStore 5000T, PowerStore 500T, PowerStore 5200T, PowerStore 7000T, PowerStore 9000T

产品

PowerStore 9200T, PowerStoreOS
文章属性
文章编号: 000228564
文章类型: Solution
上次修改时间: 14 2月 2025
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。