Устранение проблем восстановления ВМ с мгновенным доступом и ошибкой esx_splitter

摘要: Проблема восстановления виртуальной машины с мгновенным доступом. Эта проблема возникала при восстановлении виртуальной машины (ВМ) в другой виртуальный центр (ВЦ) с помощью мгновенного доступа, что приводило к сбою включения питания из-за невозможности создать виртуальное устройство SCSI. Сообщение об ошибке указывает на проблему с фильтром «esx_splitter», установленным RP4VM. Чтобы решить эту проблему, удалите существующее устройство SCSI из параметров виртуальной машины или закомментируйте строки, содержащие «esx_splitter» в файле .vmx. ...

本文适用于 本文不适用于 本文并非针对某种特定的产品。 本文并非包含所有产品版本。

症状

Клиент восстановил одну виртуальную машину в другой VC с помощью мгновенного доступа. Задание IA успешно завершено, но нам не удалось запустить новую виртуальную машину.

  • Сообщение об ошибке:
    • Module DevicePowerOn power on failed.
    • Unable to create virtual SCSI device for scsi0:0, ‘/vmfs/volumes/xxxxxxx.vmdk’
    • Failed to attach filter ‘esx_splitter ‘ to scsi0:0: Not found (195887107).

 

原因

Проблема восстановления виртуальной машины вызвана определенным состоянием, при котором исходная виртуальная машина восстанавливается в другой виртуальный центр (VC) с помощью мгновенного доступа (IA). Задание IA завершается успешно, но новая виртуальная машина не запускается из-за сбоя создания виртуального устройства SCSI.

  • Сообщение об ошибке указывает на сбой создания виртуального устройства SCSI для указанного файла VMDK, что приводит к ошибке «Module DevicePowerOn power on failed».
  • В сообщении об ошибке также упоминается невозможность подключения фильтра «esx_splitter» к устройству SCSI с кодом ошибки «Не найдено (195887107)».
  • Эта проблема возникает при восстановлении виртуальной машины с хоста ESXi, защищенного RP4VM, на другой хост ESXi, не защищенный RP4VM.
  • Наличие фильтра «esx_splitter», установленного RP4VM, является ключевым фактором сбоя при запуске новой ВМ.
  • Исходная виртуальная машина работает нормально. Кроме того, исходная, целевая версия VC и версия хоста ESXi согласуются.
  • Удаление существующего устройства SCSI и повторное его добавление устраняет проблему, указывающую на проблему, связанную с конфигурацией.
Внимание! Эта проблема характерна для хостов ESXi, защищенных RP4VM, и восстановления виртуальных машин на хостах ESXi, не защищенных RP4VM.

解决方案

Решение проблемы восстановления виртуальной машины — удаление устройства SCSI из настроек виртуальной машины или комментирование строк, содержащих «esx_splitter» в файле .vmx

Пошаговое руководство

  1. Удаление устройства SCSI из параметров виртуальной машины:
    1. Перейдите к настройкам виртуальной машины на сервере vCenter Server.
    2. Перейдите на вкладку Оборудование.
    3. Прокрутите вниз до раздела SCSI Controller .
    4. Нажмите кнопку Remove рядом с SCSI-устройством.
    5. Подтвердите, что хотите удалить устройство.
  2. Закомментируйте «esx_splitter» в файле .vmx:
    1. Откройте файл .vmx в текстовом редакторе.
    2. Поиск строк, содержащих «esx_splitter».
    3. Закомментируйте эти строки, добавив символ '#' в начале каждой строки.
    4. Сохраните изменения в файле .vmx.

Проверка того, что проблема устранена

После удаления устройства SCSI или добавления комментария «esx_splitter» в файле .vmx попробуйте снова включить виртуальную машину.

Если виртуальная машина успешно включится, проблема устранена.

Инструменты и ресурсы

Клиент vSphere Client можно использовать для управления параметрами виртуальных машин и файлом .vmx.

Дополнительные сведения о проблеме «esx_splitter» см. в статье базы знаний: База знаний по развертыванию. не удается включить виртуальную машину на хосте ESXi в хранилище CR

Warning

Внимание! Удаление устройства SCSI или закомментирование файла «esx_splitter» в файле .vmx может привести к потере или повреждению данных, если это сделано неправильно. Перед выполнением этих действий обязательно создайте резервную копию виртуальной машины.

受影响的产品

Avamar Server
文章属性
文章编号: 000231764
文章类型: Solution
上次修改时间: 06 3月 2025
版本:  3
从其他戴尔用户那里查找问题的答案
支持服务
检查您的设备是否在支持服务涵盖的范围内。