PowerStore: Etter en oppgradering til PowerStore til 2.0.x.x eller 2.1.x.x, er volumer ikke lenger tilgjengelige for direkte tilkoblede FC-verter

摘要: Etter en oppgradering til PowerStore til 2.0.x.x eller 2.1.x.x kan direktetilknyttede verter som har NVMe-kompatible drivere, miste tilgangen til alle volumer.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

En vert kan miste tilgangen til volumer etter powerstore-oppgradering til den berørte versjonen.
Hvis PowerStore tidligere ble oppgradert til den berørte versjonen uten problemer, kan oppdatering av vertsdriverne til en versjon som støtter NVMe, avdekke dette problemet.

原因

Etter at vertene er oppdatert for å støtte NVMe, kan det forekomme en ny prosesspålogging (PRLI) fra verten etter hver koblingshendelse. Denne andre PRLI-en er for NVMe-transport, og PowerStore håndterer ikke denne andre PRLI-en optimalt.

解析度

Dette problemet vil bli løst i en fremtidig utgivelse av PowerStoreOS.
Deaktiver NVMe-støtte i driveren som en løsning.

 

For ESXi-verter kan du se VMware KB 84325. Sammendrag nedenfor.
 
ESXi bruker QLogic- eller Marvel HBA- og qlnativefc-driver:
esxcfg-module -s 'ql2xnvmesupport=0' qlnativefc
 
ESXi bruker Emulex HBA- og lpfc-driver:
esxcli system module parameters set -m lpfc -p lpfc_enable_fc4_type=1
 
 
For Red Hat-verter kan du se KB 3522911. Sammendrag nedenfor.
 
Linux-vert som bruker QLogic- eller Marvel HBA- og qlnativefc-driver, legger til eller redigerer linjen nedenfor:
vi /etc/modprobe.d/qla2xxx.conf
ql2xnvmeenable=0
 
Linux-vert som bruker Emulex HBA- og lpfc-driver, redigerer følgende fil og legger til eller redigerer linjen nedenfor:
vi /etc/modprobe.d/lpfc.conf
 lpfc lpfc_enable_fc4_type=1

Vertene må startes på nytt etter at HBA-driverkonfigurasjonen er endret.

受影響的產品

PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000X, PowerStore 9000T
文章屬性
文章編號: 000200588
文章類型: Solution
上次修改時間: 14 6月 2023
版本:  14
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。