PowerProtect Data Manager | SQL database assets removed from Policy

摘要: PowerProtect Data Manager (PPDM) SQL asset backups are automatically removed from policy. The customer has to manually add the assets back for the backups to happen again.

本文章適用於 本文章不適用於 本文無關於任何特定產品。 本文未識別所有產品版本。

症狀

Assets are count for SQL protection policy is set to 0.

CBS Logs show the unassignment calls:
 
2023-01-29T17:10:12.395Z INFO [] [https-jsse-nio-127.0.0.1-8445-exec-47] [][][][TRACE_ID:b5badb32fb0ec1fb][] [c.e.b.c.f.RestLogFilter.doFilter(43)] - Enter RESTful Msg - Method: POST , Path: https://localhost:8443/api/v2/protection-policies/aff733d6-280a-4d2c-a3bb-053ad35ee832/asset-unassignments 2023-01-29T17:10:12.398Z INFO [] [https-jsse-nio-127.0.0.1-8445-exec-47] [][][][TRACE_ID:b5badb32fb0ec1fb][]

SQL policy screen 1
 




SQL policy screen 2
 

原因

This issue appears to be caused by SQL server, or services become unavailable. When asset discovery runs, it marks these missing (unavailable) assets as deleted.
 
253788:2023-02-23T21:22:00.607Z INFO [] [notificationActorSystem-akka.actor.default-dispatcher-6855] [][][][][] [c.e.d.e.a.s.h.AssetActorHandler.isDeletedinHostAndGcedInEs(937)] -  Asset with natural ids: [R019PxRr0ARm7gH27_QFHrp4CngOz8IrRhpofRD0vyvM8k=] is either in deleted State or deleted/Not detected/GCed from ES. So skipping the discovery processing for this asset.
253789:2023-02-23T21:22:00.610Z INFO [] [notificationActorSystem-akka.actor.default-dispatcher-6855] [][][][][] [c.e.d.e.a.s.h.AssetActorHandler.isDeletedinHostAndGcedInEs(937)] -  Asset with natural ids: [R01KjoOTC-IRlrJVZeOyqeLBqKVMKor_3nQXpRJ9YOnJ8k=] is either in deleted State or deleted/Not detected/GCed from ES. So skipping the discovery processing for this asset.


解析度

This issue has been fixed in build 19.13.x onwards. If the SQL services are down and discovery happens before SQL databases are available, the assets are marked as "not detected" instead of "deleted."

In v19.13, since databases are not marked as "deleted" they are not removed from the policy.
文章屬性
文章編號: 000212443
文章類型: Solution
上次修改時間: 02 6月 2023
版本:  2
向其他 Dell 使用者尋求您問題的答案
支援服務
檢查您的裝置是否在支援服務的涵蓋範圍內。